aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-09-22 13:59:02 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2009-09-22 14:18:20 +0000
commit4cee685cd690316111cbdc02043747b57fff40a7 (patch)
treeb510095088c631150f4a55bf08b5130f647755f2 /recipes/shr
parentc5563c00d67e73b3f2d06a229758bfcda6952dab (diff)
downloadopenembedded-4cee685cd690316111cbdc02043747b57fff40a7.tar.gz
shr-splash*: Different splash themes (from SHR)
Diffstat (limited to 'recipes/shr')
-rw-r--r--recipes/shr/shr-splash-theme-dontpanic_git.bb10
-rw-r--r--recipes/shr/shr-splash-theme-handy_git.bb10
-rw-r--r--recipes/shr/shr-splash-theme-niebiee_git.bb11
-rw-r--r--recipes/shr/shr-splash-theme-simple_git.bb13
-rw-r--r--recipes/shr/shr-splash-theme.inc23
-rw-r--r--recipes/shr/shr-splash_git.bb34
6 files changed, 101 insertions, 0 deletions
diff --git a/recipes/shr/shr-splash-theme-dontpanic_git.bb b/recipes/shr/shr-splash-theme-dontpanic_git.bb
new file mode 100644
index 0000000000..4bf41fbd29
--- /dev/null
+++ b/recipes/shr/shr-splash-theme-dontpanic_git.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "SHR splash screen - DON'T PANIC theme"
+SECTION = "x11/data"
+LICENSE = "MIT BSD"
+PV = "1.2-gitr${SRCREV}"
+PR = "r6"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/shr-splash/${PN}"
+
+require shr-splash-theme.inc
diff --git a/recipes/shr/shr-splash-theme-handy_git.bb b/recipes/shr/shr-splash-theme-handy_git.bb
new file mode 100644
index 0000000000..773d4f16db
--- /dev/null
+++ b/recipes/shr/shr-splash-theme-handy_git.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "SHR splash screen - handy theme"
+SECTION = "x11/data"
+LICENSE = "MIT BSD"
+PV = "1.2-gitr${SRCREV}"
+PR = "r3"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/shr-splash/${PN}"
+
+require shr-splash-theme.inc
diff --git a/recipes/shr/shr-splash-theme-niebiee_git.bb b/recipes/shr/shr-splash-theme-niebiee_git.bb
new file mode 100644
index 0000000000..40a0973f2b
--- /dev/null
+++ b/recipes/shr/shr-splash-theme-niebiee_git.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "SHR splash screen - extremely blue Niebiee theme"
+SECTION = "x11/data"
+LICENSE = "MIT BSD"
+PV = "1.2-gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/shr-splash/${PN}"
+
+require shr-splash-theme.inc
+
diff --git a/recipes/shr/shr-splash-theme-simple_git.bb b/recipes/shr/shr-splash-theme-simple_git.bb
new file mode 100644
index 0000000000..865e18fce7
--- /dev/null
+++ b/recipes/shr/shr-splash-theme-simple_git.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "SHR splash screen - simple SHR theme"
+SECTION = "x11/data"
+LICENSE = "MIT BSD"
+PV = "1.2-gitr${SRCREV}"
+PR = "r6"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/shr-splash/${PN}"
+
+ALTERNATIVE_PRIORITY = 2
+
+require shr-splash-theme.inc
+
diff --git a/recipes/shr/shr-splash-theme.inc b/recipes/shr/shr-splash-theme.inc
new file mode 100644
index 0000000000..50e62bcb7e
--- /dev/null
+++ b/recipes/shr/shr-splash-theme.inc
@@ -0,0 +1,23 @@
+RPROVIDES_${PN} = "virtual/shr-splash-theme"
+RDEPENDS += "shr-splash"
+
+inherit update-alternatives
+
+FILES_${PN} = "${datadir}/shr-splash/themes/${PN}"
+
+ALTERNATIVE_NAME = "shr-splash-theme"
+ALTERNATIVE_LINK = "${datadir}/shr-splash/theme"
+ALTERNATIVE_PATH = "${datadir}/shr-splash/themes/${PN}"
+ALTERNATIVE_PRIORITY ?= 1
+
+do_install() {
+ install -d ${D}${datadir}/shr-splash/themes/${PN}
+
+ install -m 0644 ${S}/xsplash-vga.ppm ${D}${datadir}/shr-splash/themes/${PN}/xsplash-vga.ppm
+ install -m 0644 ${S}/boot.fbz ${D}${datadir}/shr-splash/themes/${PN}/boot.fbz
+ install -m 0644 ${S}/shutdown.fbz ${D}${datadir}/shr-splash/themes/${PN}/shutdown.fbz
+ install -m 0644 ${S}/name ${D}${datadir}/shr-splash/themes/${PN}/name
+ install -m 0644 ${S}/author ${D}${datadir}/shr-splash/themes/${PN}/author
+ install -m 0644 ${S}/preview.png ${D}${datadir}/shr-splash/themes/${PN}/preview.png
+}
+
diff --git a/recipes/shr/shr-splash_git.bb b/recipes/shr/shr-splash_git.bb
new file mode 100644
index 0000000000..1ce7373e82
--- /dev/null
+++ b/recipes/shr/shr-splash_git.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "SHR splash screen"
+SECTION = "x11/data"
+LICENSE = "MIT BSD"
+PV = "1.2-gitr${SRCREV}"
+PR = "r4"
+RRECOMMENDS_${PN} += "\
+ virtual/shr-splash-theme"
+
+inherit update-rc.d
+
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/${PN}"
+
+FILES_${PN} = "${datadir}/shr-splash \
+ ${sysconfdir}/init.d/shr-splash.sh \
+"
+
+do_install() {
+ install -d ${D}${datadir}/shr-splash
+ install -d ${D}${datadir}/shr-splash/themes
+ install -d ${D}${sysconfdir}/init.d
+
+ install -m 0755 ${S}/shr-splash.sh ${D}${sysconfdir}/init.d/shr-splash.sh
+
+}
+
+pkg_postinst() {
+ [ -e ${datadir}/pixmaps/xsplash-vga.ppm ] || ln -s ${datadir}/shr-splash/theme/xsplash-vga.ppm ${datadir}/pixmaps/xsplash-vga.ppm
+}
+
+
+INITSCRIPT_NAME = "shr-splash.sh"
+INITSCRIPT_PARAMS = "start 01 S . stop 21 0 1 6 ."