aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr/shr-splash_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/shr/shr-splash_git.bb')
-rw-r--r--recipes/shr/shr-splash_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/shr/shr-splash_git.bb b/recipes/shr/shr-splash_git.bb
new file mode 100644
index 0000000000..1ce7373e82
--- /dev/null
+++ b/recipes/shr/shr-splash_git.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "SHR splash screen"
+SECTION = "x11/data"
+LICENSE = "MIT BSD"
+PV = "1.2-gitr${SRCREV}"
+PR = "r4"
+RRECOMMENDS_${PN} += "\
+ virtual/shr-splash-theme"
+
+inherit update-rc.d
+
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/${PN}"
+
+FILES_${PN} = "${datadir}/shr-splash \
+ ${sysconfdir}/init.d/shr-splash.sh \
+"
+
+do_install() {
+ install -d ${D}${datadir}/shr-splash
+ install -d ${D}${datadir}/shr-splash/themes
+ install -d ${D}${sysconfdir}/init.d
+
+ install -m 0755 ${S}/shr-splash.sh ${D}${sysconfdir}/init.d/shr-splash.sh
+
+}
+
+pkg_postinst() {
+ [ -e ${datadir}/pixmaps/xsplash-vga.ppm ] || ln -s ${datadir}/shr-splash/theme/xsplash-vga.ppm ${datadir}/pixmaps/xsplash-vga.ppm
+}
+
+
+INITSCRIPT_NAME = "shr-splash.sh"
+INITSCRIPT_PARAMS = "start 01 S . stop 21 0 1 6 ."