aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fbv
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-02-26 22:14:53 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-02-26 22:50:53 +0100
commitc9c44dd2fb216ff5185cb87f8424f3192f73b94b (patch)
tree54880b5efed8c85354a5b5e94e2de2b86c24c00f /recipes/fbv
parent106d2dcc40667f4370f936c16a52dccb14d9f759 (diff)
downloadopenembedded-c9c44dd2fb216ff5185cb87f8424f3192f73b94b.tar.gz
fbv: fix cflags and libs and enable libungif
* remove missleading patch * bump PR
Diffstat (limited to 'recipes/fbv')
-rw-r--r--recipes/fbv/fbv-1.0b/cflags.patch13
-rw-r--r--recipes/fbv/fbv-1.0b/fbv-1.0b.patch12
-rw-r--r--recipes/fbv/fbv-1.0b/libs.patch13
-rw-r--r--recipes/fbv/fbv_1.0b.bb14
4 files changed, 34 insertions, 18 deletions
diff --git a/recipes/fbv/fbv-1.0b/cflags.patch b/recipes/fbv/fbv-1.0b/cflags.patch
new file mode 100644
index 0000000000..1259c6b511
--- /dev/null
+++ b/recipes/fbv/fbv-1.0b/cflags.patch
@@ -0,0 +1,13 @@
+Index: fbv-1.0b/Makefile
+===================================================================
+--- fbv-1.0b.orig/Makefile 2011-02-26 21:50:39.786273304 +0100
++++ fbv-1.0b/Makefile 2011-02-26 21:53:44.051693304 +0100
+@@ -6,7 +6,7 @@
+ include Make.conf
+
+ CC = gcc
+-CFLAGS = -O2 -Wall -D_GNU_SOURCE
++CFLAGS += -D_GNU_SOURCE
+
+ SOURCES = main.c jpeg.c gif.c png.c bmp.c fb_display.c transforms.c
+ OBJECTS = ${SOURCES:.c=.o}
diff --git a/recipes/fbv/fbv-1.0b/fbv-1.0b.patch b/recipes/fbv/fbv-1.0b/fbv-1.0b.patch
deleted file mode 100644
index 2ca9d522b9..0000000000
--- a/recipes/fbv/fbv-1.0b/fbv-1.0b.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN fbv-1.0b-0rig/Makefile fbv-1.0b/Makefile
---- fbv-1.0b-0rig/Makefile 2009-08-20 00:33:58.000000000 +0200
-+++ fbv-1.0b/Makefile 2009-08-20 00:34:16.000000000 +0200
-@@ -12,7 +12,7 @@
- OBJECTS = ${SOURCES:.c=.o}
-
- OUT = fbv
--#LIBS = -lungif -L/usr/X11R6/lib -ljpeg -lpng
-+LIBS = -L/usr/lib -ljpeg -lpng #-lungif
-
- all: $(OUT)
- @echo Build DONE.
diff --git a/recipes/fbv/fbv-1.0b/libs.patch b/recipes/fbv/fbv-1.0b/libs.patch
new file mode 100644
index 0000000000..47f5d918ed
--- /dev/null
+++ b/recipes/fbv/fbv-1.0b/libs.patch
@@ -0,0 +1,13 @@
+Index: fbv-1.0b/Makefile
+===================================================================
+--- fbv-1.0b.orig/Makefile 2004-09-07 14:34:29.000000000 +0200
++++ fbv-1.0b/Makefile 2011-02-26 22:11:03.217683306 +0100
+@@ -12,7 +12,7 @@
+ OBJECTS = ${SOURCES:.c=.o}
+
+ OUT = fbv
+-#LIBS = -lungif -L/usr/X11R6/lib -ljpeg -lpng
++#LIBS = -lungif -ljpeg -lpng
+
+ all: $(OUT)
+ @echo Build DONE.
diff --git a/recipes/fbv/fbv_1.0b.bb b/recipes/fbv/fbv_1.0b.bb
index 3629fe4d93..d8ca180642 100644
--- a/recipes/fbv/fbv_1.0b.bb
+++ b/recipes/fbv/fbv_1.0b.bb
@@ -1,21 +1,23 @@
DESCRIPTION = "Frame Buffer Viewer"
LICENSE = "GPL"
-DEPENDS = "libpng jpeg"
-PR = "r3"
+DEPENDS = "libpng jpeg libungif"
+PR = "r4"
SRC_URI = "http://s-tech.elsat.net.pl/fbv/fbv-1.0b.tar.gz \
file://cross_compile.patch \
- file://fbv-1.0b.patch \
file://fbv-1.0b-BGR666.patch \
+ file://libs.patch \
+ file://cflags.patch \
"
+CFLAGS += "-D_GNU_SOURCE -D__KERNEL_STRICT_NAMES"
+
do_configure() {
- CC="${CC}" ./configure --without-libungif
+ CC="${CC}" ./configure
}
do_compile() {
- oe_runmake CC="${CC}" \
- CFLAGS="-O2 -Wall -D_GNU_SOURCE -D__KERNEL_STRICT_NAMES"
+ oe_runmake CC="${CC}"
}
do_install() {