aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fbv/fbv_1.0b.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fbv/fbv_1.0b.bb')
-rw-r--r--recipes/fbv/fbv_1.0b.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes/fbv/fbv_1.0b.bb b/recipes/fbv/fbv_1.0b.bb
index 3629fe4d93..d8ca180642 100644
--- a/recipes/fbv/fbv_1.0b.bb
+++ b/recipes/fbv/fbv_1.0b.bb
@@ -1,21 +1,23 @@
DESCRIPTION = "Frame Buffer Viewer"
LICENSE = "GPL"
-DEPENDS = "libpng jpeg"
-PR = "r3"
+DEPENDS = "libpng jpeg libungif"
+PR = "r4"
SRC_URI = "http://s-tech.elsat.net.pl/fbv/fbv-1.0b.tar.gz \
file://cross_compile.patch \
- file://fbv-1.0b.patch \
file://fbv-1.0b-BGR666.patch \
+ file://libs.patch \
+ file://cflags.patch \
"
+CFLAGS += "-D_GNU_SOURCE -D__KERNEL_STRICT_NAMES"
+
do_configure() {
- CC="${CC}" ./configure --without-libungif
+ CC="${CC}" ./configure
}
do_compile() {
- oe_runmake CC="${CC}" \
- CFLAGS="-O2 -Wall -D_GNU_SOURCE -D__KERNEL_STRICT_NAMES"
+ oe_runmake CC="${CC}"
}
do_install() {