aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-04 10:45:23 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-04 11:27:18 +0100
commit8ac85f656c678b4e0cb458e8e5876f4c37756eff (patch)
treec44d04c178875ad350583bc1b0b2fc05b8156b31 /recipes/e17
parent4dcaca2917c61d8858e4a86ed84f32435e119c79 (diff)
downloadopenembedded-8ac85f656c678b4e0cb458e8e5876f4c37756eff.tar.gz
exalt: update to current form
Diffstat (limited to 'recipes/e17')
-rw-r--r--recipes/e17/exalt-client_svn.bb23
-rw-r--r--recipes/e17/exalt_svn.bb33
2 files changed, 56 insertions, 0 deletions
diff --git a/recipes/e17/exalt-client_svn.bb b/recipes/e17/exalt-client_svn.bb
new file mode 100644
index 0000000000..469a95554a
--- /dev/null
+++ b/recipes/e17/exalt-client_svn.bb
@@ -0,0 +1,23 @@
+LICENSE = "LGPLv2"
+PV = "0.0.1+svnr${SRCREV}"
+
+require e-module.inc
+
+DEPENDS += "elementary exalt edje-native"
+
+CFLAGS += " -I${STAGING_INCDIR}/exalt -I${STAGING_INCDIR}/exalt_dbus"
+
+do_configure_prepend() {
+ sed -i -e /po/d configure.ac
+ sed -i -e s:\ po::g Makefile.am
+}
+
+FILES_${PN} += "${libdir}/enlightenment/modules/*/*.desktop \
+ ${libdir}/enlightenment/modules/*/*.edj \
+ ${libdir}/enlightenment/modules/*/*/*.so"
+
+FILES_${PN}-static += "${libdir}/enlightenment/modules/*/*/*.a"
+FILES_${PN}-dev += "${libdir}/enlightenment/modules/*/*/*.la"
+FILES_${PN}-dbg += "${libdir}/enlightenment/modules/*/*/.debug"
+
+
diff --git a/recipes/e17/exalt_svn.bb b/recipes/e17/exalt_svn.bb
new file mode 100644
index 0000000000..8868296736
--- /dev/null
+++ b/recipes/e17/exalt_svn.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Exalt is a network manager for the windows manager Enlightenment DR17."
+HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
+
+LICENSE = "LGPLv2"
+DEPENDS = "elementary vpnc wpa-supplicant ecore eet edbus"
+RDEPENDS = "vpnc wpa-supplicant"
+
+PV = "0.9+svnr${SRCREV}"
+
+inherit e
+
+EXTRA_OECONF = " \
+--with-wpa_supplicant=${sbindir}/wpa_supplicant \
+--with-vpnc=${sbindir}/vpnc \
+--with-vpnc-disconnect=${sbindir}/vpnc-disconnect \
+"
+
+do_install_append() {
+ # install dbus config file
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0644 data/daemon/dbus/exalt.conf ${D}${sysconfdir}/dbus-1/system.d/exalt.conf
+
+ # install dbus service file
+ install -d ${D}${datadir}/dbus-1/system-services/
+ install -m 0644 org.e.Exalt.service ${D}${datadir}/dbus-1/system-services/
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/dbus-1"
+