aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17/exalt-client_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/e17/exalt-client_svn.bb')
-rw-r--r--recipes/e17/exalt-client_svn.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/e17/exalt-client_svn.bb b/recipes/e17/exalt-client_svn.bb
new file mode 100644
index 0000000000..469a95554a
--- /dev/null
+++ b/recipes/e17/exalt-client_svn.bb
@@ -0,0 +1,23 @@
+LICENSE = "LGPLv2"
+PV = "0.0.1+svnr${SRCREV}"
+
+require e-module.inc
+
+DEPENDS += "elementary exalt edje-native"
+
+CFLAGS += " -I${STAGING_INCDIR}/exalt -I${STAGING_INCDIR}/exalt_dbus"
+
+do_configure_prepend() {
+ sed -i -e /po/d configure.ac
+ sed -i -e s:\ po::g Makefile.am
+}
+
+FILES_${PN} += "${libdir}/enlightenment/modules/*/*.desktop \
+ ${libdir}/enlightenment/modules/*/*.edj \
+ ${libdir}/enlightenment/modules/*/*/*.so"
+
+FILES_${PN}-static += "${libdir}/enlightenment/modules/*/*/*.a"
+FILES_${PN}-dev += "${libdir}/enlightenment/modules/*/*/*.la"
+FILES_${PN}-dbg += "${libdir}/enlightenment/modules/*/*/.debug"
+
+