aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-27 17:32:26 -0700
committerChris Larson <chris_larson@mentor.com>2011-01-26 14:28:53 -0700
commitaf5f4debf19be227c63d5cc89e4acd2961469724 (patch)
treef06deae8d0a72952d78fa3605e412f354a36446c
parent0bf1d00fb4e2b36dc3c25194bdddc6d95300caf4 (diff)
downloadopenembedded-af5f4debf19be227c63d5cc89e4acd2961469724.tar.gz
Add install wrapper rather than coreutils-native
Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Eric BĂ©nard <eric@eukrea.com> Acked-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
-rwxr-xr-xbin/darwin/cp2
-rwxr-xr-xbin/darwin/sed2
-rwxr-xr-xbin/install35
-rw-r--r--classes/base.bbclass28
-rw-r--r--classes/gpe.bbclass2
-rw-r--r--classes/gpephone.bbclass2
-rw-r--r--recipes/twin/twin_0.4.6.bb1
7 files changed, 48 insertions, 24 deletions
diff --git a/bin/darwin/cp b/bin/darwin/cp
index 0a523b7987..a753557cea 100755
--- a/bin/darwin/cp
+++ b/bin/darwin/cp
@@ -7,7 +7,7 @@
# - Otherwise, we stick to what SuSv3 defines
-source $(dirname $0)/wrapper.sh
+source $(dirname $0)/../wrapper.sh
saved=""
while getopts fpaRHLP opt; do
diff --git a/bin/darwin/sed b/bin/darwin/sed
index 352a3ca6e8..f52d09f075 100755
--- a/bin/darwin/sed
+++ b/bin/darwin/sed
@@ -21,7 +21,7 @@
# to reimplement -i internally in this script on some platforms.
-source $(dirname $0)/wrapper.sh
+source $(dirname $0)/../wrapper.sh
case `uname -s` in
Darwin)
diff --git a/bin/install b/bin/install
new file mode 100755
index 0000000000..a587fa0096
--- /dev/null
+++ b/bin/install
@@ -0,0 +1,35 @@
+#!/bin/sh
+
+source $(dirname $0)/wrapper.sh
+
+saved=""
+while getopts dbCcMpSsvB:f:g:m:o:D opt; do
+ case "$opt" in
+ s)
+ # Ignore strip argument
+ ;;
+ B|f|g|m|o)
+ save "-$opt"
+ save "$OPTARG"
+ ;;
+ D)
+ createleading="1"
+ ;;
+ \?)
+ exit 1
+ ;;
+ *)
+ save "-$opt"
+ ;;
+ esac
+done
+shift $(($OPTIND - 1))
+for arg; do
+ save "$arg"
+done
+
+if [ $# == 2 -a -n "$createleading" ]; then
+ install -d $(dirname $2)
+fi
+
+exec_real
diff --git a/classes/base.bbclass b/classes/base.bbclass
index fdffcfabaa..fc962eec72 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -57,33 +57,23 @@ oe_runmake() {
}
def base_deps(d):
- #
- # Ideally this will check a flag so we will operate properly in
- # the case where host == build == target, for now we don't work in
- # that case though.
- #
- deps = "coreutils-native"
- if bb.data.getVar('PN', d, True) in ("shasum-native", "coreutils-native"):
- deps = ""
-
# INHIBIT_DEFAULT_DEPS doesn't apply to the patch command. Whether or not
# we need that built is the responsibility of the patch function / class, not
# the application.
if not bb.data.getVar('INHIBIT_DEFAULT_DEPS', d):
if (bb.data.getVar('HOST_SYS', d, 1) !=
- bb.data.getVar('BUILD_SYS', d, 1)):
- deps += " virtual/${TARGET_PREFIX}gcc virtual/libc "
+ bb.data.getVar('BUILD_SYS', d, 1)):
+ return "virtual/${TARGET_PREFIX}gcc virtual/libc"
elif bb.data.inherits_class('native', d) and \
bb.data.getVar('PN', d, True) not in \
("linux-libc-headers-native", "quilt-native",
- "unifdef-native", "shasum-native",
- "coreutils-native"):
- deps += " linux-libc-headers-native"
- return deps
+ "unifdef-native", "shasum-native"):
+ return "linux-libc-headers-native"
+ return ""
-DEPENDS_prepend="${@base_deps(d)} "
-DEPENDS_virtclass-native_prepend="${@base_deps(d)} "
-DEPENDS_virtclass-nativesdk_prepend="${@base_deps(d)} "
+DEPENDS_prepend = "${@base_deps(d)} "
+DEPENDS_virtclass-native_prepend = "${@base_deps(d)} "
+DEPENDS_virtclass-nativesdk_prepend = "${@base_deps(d)} "
SCENEFUNCS += "base_scenefunction"
@@ -92,7 +82,7 @@ SCENEFUNCS[type] = "list"
python base_scenefunction () {
stamp = bb.data.getVar('STAMP', d, 1) + ".needclean"
if os.path.exists(stamp):
- bb.build.exec_func("do_clean", d)
+ bb.build.exec_func("do_clean", d)
}
python base_do_setscene () {
diff --git a/classes/gpe.bbclass b/classes/gpe.bbclass
index a9ddec3b53..7e042ee930 100644
--- a/classes/gpe.bbclass
+++ b/classes/gpe.bbclass
@@ -1,4 +1,4 @@
-DEPENDS_prepend = "coreutils-native virtual/libintl intltool-native "
+DEPENDS_prepend = "virtual/libintl intltool-native "
GPE_TARBALL_SUFFIX ?= "gz"
SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.${GPE_TARBALL_SUFFIX}"
FILES_${PN} += "${datadir}/gpe ${datadir}/application-registry"
diff --git a/classes/gpephone.bbclass b/classes/gpephone.bbclass
index 57867b5d4b..dffbaa975f 100644
--- a/classes/gpephone.bbclass
+++ b/classes/gpephone.bbclass
@@ -1,4 +1,4 @@
-DEPENDS_prepend = "coreutils-native virtual/libintl intltool-native "
+DEPENDS_prepend = "virtual/libintl intltool-native "
GPE_TARBALL_SUFFIX ?= "gz"
SRC_URI = "${GPEPHONE_MIRROR}/${PN}-${PV}/${PN}-${PV}.tar.${GPE_TARBALL_SUFFIX}"
FILES_${PN} += "${datadir}/gpe ${datadir}/application-registry"
diff --git a/recipes/twin/twin_0.4.6.bb b/recipes/twin/twin_0.4.6.bb
index c6c3fbdc5a..3ea36f8718 100644
--- a/recipes/twin/twin_0.4.6.bb
+++ b/recipes/twin/twin_0.4.6.bb
@@ -1,7 +1,6 @@
DESCRIPTION = "Twin is a text-mode windowing environment: it draws and manages text windows on a text-mode display, like X11 does for graphical windows. It has a built-in window manager and terminal emulator, and can be used as server for remote clients in the same style as X11. It can display on Linux console, on X11 and inside itself."
SECTION = "console/utils"
-DEPENDS = "coreutils-native"
LICENSE = "GPL LGPL"
SRC_URI = "http://linuz.sns.it/~max/twin/twin-0.4.6.tar.gz \
file://cross_compile.patch"