aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-27 17:29:52 -0700
committerChris Larson <chris_larson@mentor.com>2011-01-26 14:28:29 -0700
commit0bf1d00fb4e2b36dc3c25194bdddc6d95300caf4 (patch)
tree7a1a2b8c8598a659da4bf196263e7f0ab94136de
parentc1c058fc29f916c2f000bb7195f6195e271873b0 (diff)
downloadopenembedded-0bf1d00fb4e2b36dc3c25194bdddc6d95300caf4.tar.gz
Move stage-manager-* into bin/ rather than a recipe
Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Eric BĂ©nard <eric@eukrea.com>
-rwxr-xr-xbin/stage-manager (renamed from recipes/stage-manager/files/stage-manager)3
-rwxr-xr-xbin/stage-manager-opkg (renamed from recipes/stage-manager/files/stage-manager-opkg)0
-rwxr-xr-xbin/stage-manager-opkg-build (renamed from recipes/stage-manager/files/stage-manager-opkg-build)0
-rw-r--r--classes/base.bbclass5
-rw-r--r--classes/packaged-staging.bbclass5
-rw-r--r--recipes/stage-manager/stagemanager-native_0.0.1.bb26
6 files changed, 2 insertions, 37 deletions
diff --git a/recipes/stage-manager/files/stage-manager b/bin/stage-manager
index 4fc112d405..a7131c648a 100755
--- a/recipes/stage-manager/files/stage-manager
+++ b/bin/stage-manager
@@ -151,6 +151,3 @@ if __name__ == "__main__":
if found_difference:
sys.exit(5)
sys.exit(0)
-
-
-
diff --git a/recipes/stage-manager/files/stage-manager-opkg b/bin/stage-manager-opkg
index 5a2347a534..5a2347a534 100755
--- a/recipes/stage-manager/files/stage-manager-opkg
+++ b/bin/stage-manager-opkg
diff --git a/recipes/stage-manager/files/stage-manager-opkg-build b/bin/stage-manager-opkg-build
index b7be3dc1c7..b7be3dc1c7 100755
--- a/recipes/stage-manager/files/stage-manager-opkg-build
+++ b/bin/stage-manager-opkg-build
diff --git a/classes/base.bbclass b/classes/base.bbclass
index 25d72d4272..fdffcfabaa 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -63,8 +63,7 @@ def base_deps(d):
# that case though.
#
deps = "coreutils-native"
- if bb.data.getVar('PN', d, True) in ("shasum-native", "stagemanager-native",
- "coreutils-native"):
+ if bb.data.getVar('PN', d, True) in ("shasum-native", "coreutils-native"):
deps = ""
# INHIBIT_DEFAULT_DEPS doesn't apply to the patch command. Whether or not
@@ -78,7 +77,7 @@ def base_deps(d):
bb.data.getVar('PN', d, True) not in \
("linux-libc-headers-native", "quilt-native",
"unifdef-native", "shasum-native",
- "stagemanager-native", "coreutils-native"):
+ "coreutils-native"):
deps += " linux-libc-headers-native"
return deps
diff --git a/classes/packaged-staging.bbclass b/classes/packaged-staging.bbclass
index f217aee715..b3a164009f 100644
--- a/classes/packaged-staging.bbclass
+++ b/classes/packaged-staging.bbclass
@@ -23,7 +23,6 @@ PSTAGE_SCAN_CMD ?= "find ${PSTAGE_TMPDIR_STAGE} \( -name "*.la" -o -name "*-conf
PSTAGE_NATIVEDEPENDS = "\
shasum-native \
- stagemanager-native \
"
BB_STAMP_WHITELIST = "${PSTAGE_NATIVEDEPENDS}"
@@ -75,10 +74,6 @@ python __anonymous() {
# Add task dependencies if we're active, otherwise mark packaged staging
# as inactive.
if pstage_allowed:
- deps = bb.data.getVarFlag('do_setscene', 'depends', d) or ""
- deps += " stagemanager-native:do_populate_sysroot"
- bb.data.setVarFlag('do_setscene', 'depends', deps, d)
-
policy = bb.data.getVar("BB_STAMP_POLICY", d, True)
if policy == "whitelist" or policy == "full":
deps = bb.data.getVarFlag('do_setscene', 'recrdeptask', d) or ""
diff --git a/recipes/stage-manager/stagemanager-native_0.0.1.bb b/recipes/stage-manager/stagemanager-native_0.0.1.bb
deleted file mode 100644
index 8ad73ef614..0000000000
--- a/recipes/stage-manager/stagemanager-native_0.0.1.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-DESCRIPTION = "Helper script for packaged-staging.bbclass"
-PR = "r15"
-
-SRC_URI = "file://stage-manager \
- file://stage-manager-opkg \
- file://stage-manager-opkg-build "
-LICENSE = "GPLv2"
-
-PACKAGE_ARCH = "all"
-
-inherit native
-
-DEPENDS = " "
-PACKAGE_DEPENDS = " "
-PATCHDEPENDENCY = ""
-INHIBIT_DEFAULT_DEPS = "1"
-
-PSTAGING_DISABLED = "1"
-
-NATIVE_INSTALL_WORKS = "1"
-do_install() {
- install -d ${STAGING_BINDIR}
- install -m 0755 ${WORKDIR}/stage-manager ${STAGING_BINDIR}
- install -m 0755 ${WORKDIR}/stage-manager-opkg ${STAGING_BINDIR}
- install -m 0755 ${WORKDIR}/stage-manager-opkg-build ${STAGING_BINDIR}
-}