summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-07-30 17:17:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-19 10:42:08 +0100
commitd3e60b835c5abcf2345e761027aa520409c19efc (patch)
tree46a247986c2ea4abb09942fc5abeb4a1467fa8f7 /meta
parent58047dcf547b582211f84c6f24c21cc1aa895f1e (diff)
downloadopenembedded-core-d3e60b835c5abcf2345e761027aa520409c19efc.tar.gz
mesa: respect x11 DISTRO_FEATURE
Patch originally by Damien Lespiau <damien.lespiau@intel.com>. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-graphics/mesa/mesa-8.0.4.inc1
-rw-r--r--meta/recipes-graphics/mesa/mesa-common.inc15
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri.inc4
-rw-r--r--meta/recipes-graphics/mesa/mesa-git.inc2
-rw-r--r--meta/recipes-graphics/mesa/mesa/0004-gross-hack-to-prevent-from-install-libgl.patch29
5 files changed, 41 insertions, 10 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-8.0.4.inc b/meta/recipes-graphics/mesa/mesa-8.0.4.inc
index d9d17bb5fd..9afb35dee6 100644
--- a/meta/recipes-graphics/mesa/mesa-8.0.4.inc
+++ b/meta/recipes-graphics/mesa/mesa-8.0.4.inc
@@ -5,6 +5,7 @@ SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
file://0002-cross-compile.patch \
file://0003-fix-for-x32.patch \
"
+SRC_URI += "${@base_contains('DISTRO_FEATURES', 'x11', '', 'file://0004-gross-hack-to-prevent-from-install-libgl.patch', d)}"
S = "${WORKDIR}/Mesa-${PV}"
diff --git a/meta/recipes-graphics/mesa/mesa-common.inc b/meta/recipes-graphics/mesa/mesa-common.inc
index 24cc3d08ea..feb152b13d 100644
--- a/meta/recipes-graphics/mesa/mesa-common.inc
+++ b/meta/recipes-graphics/mesa/mesa-common.inc
@@ -12,14 +12,10 @@ SECTION = "x11"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://docs/license.html;md5=03ccdc4c379c4289aecfb8892c546f67"
-INC_PR = "r1"
+INC_PR = "r2"
PE = "2"
-
-PROTO_DEPS = "xf86driproto glproto"
-LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes libxml2-native"
-
-DEPENDS = "makedepend-native flex-native bison-native ${PROTO_DEPS} ${LIB_DEPS}"
+DEPENDS = "libxml2-native makedepend-native flex-native bison-native"
PROVIDES = "virtual/libgl virtual/libgles1 virtual/libgles2"
@@ -31,10 +27,13 @@ inherit autotools pkgconfig pythonnative
EXTRA_OECONF = "--enable-glu \
--disable-glw \
--disable-glut \
- --enable-glx-tls \
--enable-shared-glapi"
-PACKAGECONFIG ??= "${@base_contains('MACHINE_FEATURES', 'x86', 'gles', '', d)}"
+PACKAGECONFIG ??= "${@base_contains('MACHINE_FEATURES', 'x86', 'gles', '', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
+
+X11_DEPS = "xf86driproto glproto virtual/libx11 libxext libxxf86vm libxdamage libxfixes"
+PACKAGECONFIG[x11] = "--enable-glx-tls,--disable-glx,${X11_DEPS}"
# Multiple virtual/gl providers being built breaks staging
EXCLUDE_FROM_WORLD = "1"
diff --git a/meta/recipes-graphics/mesa/mesa-dri.inc b/meta/recipes-graphics/mesa/mesa-dri.inc
index 32ca4b2146..ef1ca78af8 100644
--- a/meta/recipes-graphics/mesa/mesa-dri.inc
+++ b/meta/recipes-graphics/mesa/mesa-dri.inc
@@ -1,5 +1,5 @@
-PROTO_DEPS += "dri2proto"
-LIB_DEPS += "libdrm expat udev"
+DEPENDS += "libdrm expat udev"
+X11_DEPS += "dri2proto"
# most of our targets do not have DRI so will use mesa-xlib
DEFAULT_PREFERENCE = "-1"
diff --git a/meta/recipes-graphics/mesa/mesa-git.inc b/meta/recipes-graphics/mesa/mesa-git.inc
index 32b1d964a5..7910eb654d 100644
--- a/meta/recipes-graphics/mesa/mesa-git.inc
+++ b/meta/recipes-graphics/mesa/mesa-git.inc
@@ -11,6 +11,8 @@ SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git \
file://0002-cross-compile.patch \
file://0003-fix-for-x32.patch \
"
+SRC_URI += "${@base_contains('DISTRO_FEATURES', 'x11', '', 'file://0004-gross-hack-to-prevent-from-install-libgl.patch', d)}"
+
S = "${WORKDIR}/git"
do_configure_prepend() {
diff --git a/meta/recipes-graphics/mesa/mesa/0004-gross-hack-to-prevent-from-install-libgl.patch b/meta/recipes-graphics/mesa/mesa/0004-gross-hack-to-prevent-from-install-libgl.patch
new file mode 100644
index 0000000000..cf9dee25ee
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa/0004-gross-hack-to-prevent-from-install-libgl.patch
@@ -0,0 +1,29 @@
+gross hack to prevent from install libgl
+
+This patch is not suitable for upstream. This is only needed for the 8.0.x
+branch, master (8.1.x) has a largely different build system (using automake)
+and does not need it. It is fully expected to drop the patch with the next bump
+to a stable version based on 8.1.x.
+
+Upstream-Status: Inappropriate
+
+---
+ src/mesa/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/mesa/Makefile b/src/mesa/Makefile
+index 0e15d61..a0a2cb5 100644
+--- a/src/mesa/Makefile
++++ b/src/mesa/Makefile
+@@ -166,7 +166,7 @@ install: default $(DRICORE_INSTALL_TARGET)
+ else \
+ $(MAKE) install-osmesa || exit 1 ; \
+ fi ;; \
+- dri) $(MAKE) install-libgl install-dri || exit 1 ;; \
++ dri) $(MAKE) install-dri || exit 1 ;; \
+ *) $(MAKE) install-libgl || exit 1 ;; \
+ esac ; \
+ done
+--
+1.7.10.4
+