summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-08-01 13:17:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-19 10:40:41 +0100
commit58047dcf547b582211f84c6f24c21cc1aa895f1e (patch)
treeee7827f6645952219bb3e36cb7c69d76ac7fb64f /meta
parent9f83d93c65942f9ed1b25a24976f92ae06c425c8 (diff)
downloadopenembedded-core-58047dcf547b582211f84c6f24c21cc1aa895f1e.tar.gz
mesa-demos: fix GLES2 build
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos/gles2-info.patch21
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.0.1.bb5
2 files changed, 24 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos/gles2-info.patch b/meta/recipes-graphics/mesa/mesa-demos/gles2-info.patch
new file mode 100644
index 0000000000..849c974e09
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-demos/gles2-info.patch
@@ -0,0 +1,21 @@
+Fix to enable gles2 to build.
+
+Ross Burton <ross.burton@intel.com>
+
+Upstream-Status: Pending
+
+Index: mesa-demos-8.0.1/src/egl/opengles2/es2_info.c
+===================================================================
+--- mesa-demos-8.0.1.orig/src/egl/opengles2/es2_info.c 2010-07-07 18:57:15.000000000 +0100
++++ mesa-demos-8.0.1/src/egl/opengles2/es2_info.c 2012-08-01 13:14:59.000104115 +0100
+@@ -18,8 +18,8 @@
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+ #include <X11/keysym.h>
+-#include <GLES/gl.h>
+-#include <GLES/glext.h>
++#include <GLES2/gl2.h>
++#include <GLES2/gl2ext.h>
+ #include <EGL/egl.h>
+
+
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.0.1.bb b/meta/recipes-graphics/mesa/mesa-demos_8.0.1.bb
index bfc62c585f..1d16bfc392 100644
--- a/meta/recipes-graphics/mesa/mesa-demos_8.0.1.bb
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.0.1.bb
@@ -11,10 +11,11 @@ LIC_FILES_CHKSUM = "file://src/xdemos/glxgears.c;beginline=1;endline=20;md5=9142
DEPENDS = "virtual/libx11 virtual/libgl glew"
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/demos/${PV}/${BPN}-${PV}.tar.bz2 \
- file://dso_linking_change_build_fix.patch"
+ file://dso_linking_change_build_fix.patch \
+ file://gles2-info.patch"
inherit autotools pkgconfig