summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-02-06 15:53:29 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-08 10:58:31 +0000
commitf993871b656927b5be019e7ff788c6f53cb4caf6 (patch)
tree41618bebd31a68ccc8f512264a0a22cd2f43b8fb
parentb4ebf4268369c99432d2c8dc98ea13ca594c1748 (diff)
downloadopenembedded-core-f993871b656927b5be019e7ff788c6f53cb4caf6.tar.gz
linux-yocto/6.6: beaglebone: drop nonassignable kernel options
Integrating the following commit(s) to linux-yocto/.: 1/1 [ Author: Kevin Hao Email: kexin.hao@windriver.com Subject: beaglebone: Drop the nonassignable kernel options Date: Sat, 20 Jan 2024 20:19:20 +0800 These kernel options aren't assignable. In the previous version of the kernel, these options were selected by DRM_FBDEV_EMULATION. But due to the commit 43049f17b526 ("drm/i915: Implement dedicated fbdev I/O helpers") in the new version of kernel, they are no longer enabled by DRM_FBDEV_EMULATION. Then the kernel config check emits unmatch warning for them. Drop all of them to fix these warnings. Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> ] Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_6.6.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb
index 25ff894ef2..22a93880fc 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb
@@ -15,7 +15,7 @@ python () {
}
SRCREV_machine ?= "59ee8cb752a7e280cfe2d480964aa5b6c74e4203"
-SRCREV_meta ?= "80606e5b79499427524c82e4965de27e1f57c61c"
+SRCREV_meta ?= "cdacaee0449386523770415ceeded76585064265"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.6;destsuffix=${KMETA};protocol=https"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb
index b530990f20..66199674a6 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb
@@ -18,7 +18,7 @@ KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine ?= "195b2994f955071be3dd16ff61127dbc6b2e0069"
-SRCREV_meta ?= "80606e5b79499427524c82e4965de27e1f57c61c"
+SRCREV_meta ?= "cdacaee0449386523770415ceeded76585064265"
PV = "${LINUX_VERSION}+git"
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.6.bb b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
index ed722f2f80..ce9169ac76 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.6.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
@@ -29,7 +29,7 @@ SRCREV_machine:qemux86 ?= "195b2994f955071be3dd16ff61127dbc6b2e0069"
SRCREV_machine:qemux86-64 ?= "195b2994f955071be3dd16ff61127dbc6b2e0069"
SRCREV_machine:qemumips64 ?= "d41c8b84fcfcb4c2dd8eb856172cdc2b6a1bd342"
SRCREV_machine ?= "195b2994f955071be3dd16ff61127dbc6b2e0069"
-SRCREV_meta ?= "80606e5b79499427524c82e4965de27e1f57c61c"
+SRCREV_meta ?= "cdacaee0449386523770415ceeded76585064265"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
# get the <version>/base branch, which is pure upstream -stable, and the same