summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Hnatiuk <ohnatiuk@cisco.com>2023-07-21 01:18:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-07-25 15:27:30 +0100
commite76b059cf4ba9a79150032d68d012b233dd79a65 (patch)
tree7dd0bc7451500e2d4c7e3dac47855fe727bfc34d
parent8042f96a90e979374299404dbe34164f9aa65079 (diff)
downloadopenembedded-core-e76b059cf4ba9a79150032d68d012b233dd79a65.tar.gz
file: return wrapper to fix builds when file is in buildtools-tarball
Wrapper that adds proper path to magic file was removed in 47db876d09d9a4394048579c21d0b394450ce681 in favor of environment-setup.d/file.sh which now contains `MAGIC` environment variable. This breaks builds that rely on external buildtools with `file` included in buildtools-tarball (e.g. via TOOLCHAIN_HOST_TASK) because do_populate_sysroot task invokes `file` via `subprocess.check_output` (in is_elf function) and doesn't use variables from files in environment-setup.d. To address this use case, we need to preserve the wrapper, but also have environment-setup.d/file.sh for the purposes described in 47db876d09d9a4394048579c21d0b394450ce681. Signed-off-by: Oleksandr Hnatiuk <ohnatiuk@cisco.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-devtools/file/file_5.44.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.44.bb b/meta/recipes-devtools/file/file_5.44.bb
index 3090d346ed..0834384230 100644
--- a/meta/recipes-devtools/file/file_5.44.bb
+++ b/meta/recipes-devtools/file/file_5.44.bb
@@ -45,6 +45,7 @@ do_install:append:class-native() {
}
do_install:append:class-nativesdk() {
+ create_wrapper ${D}/${bindir}/file MAGIC=${datadir}/misc/magic.mgc
mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
cat <<- EOF > ${D}${SDKPATHNATIVE}/environment-setup.d/file.sh
export MAGIC="$OECORE_NATIVE_SYSROOT${datadir}/misc/magic.mgc"