summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-06-12 17:11:24 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-13 13:11:11 +0100
commitc4d0b1c5438039dab07103c151c0c5a76a4c9499 (patch)
treeece81c636f95a0907326e2acdb39a6286c09a957
parent73f10ae955ba217078fa2c5288b736ae8a30b184 (diff)
downloadopenembedded-core-c4d0b1c5438039dab07103c151c0c5a76a4c9499.tar.gz
connman: bump PR and add some comments
The comments are for informing anyone who wants to change USERADD_PARAMs to make sure it's in sync with the one in xserver-nodm-init, in order for rootless X to work. Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
-rw-r--r--meta/recipes-connectivity/connman/connman.inc4
-rw-r--r--meta/recipes-connectivity/connman/connman_0.79.bb2
-rw-r--r--meta/recipes-graphics/x11-common/xserver-nodm-init.bb2
3 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/connman/connman.inc b/meta/recipes-connectivity/connman/connman.inc
index eb174c5d34..34123234dd 100644
--- a/meta/recipes-connectivity/connman/connman.inc
+++ b/meta/recipes-connectivity/connman/connman.inc
@@ -20,6 +20,8 @@ DEPENDS = "dbus glib-2.0 ppp iptables gnutls \
${@base_contains('DISTRO_FEATURES', '3g','ofono', '', d)} \
"
+INC_PR = "r6"
+
TIST = "--enable-tist"
TIST_powerpc = ""
@@ -46,6 +48,8 @@ EXTRA_OECONF += "\
INITSCRIPT_NAME = "connman"
INITSCRIPT_PARAMS = "start 05 5 2 3 . stop 22 0 1 6 ."
+# IMPORTANT: because xuser is shared with rootless X, please make sure the
+# USERADD_PARAM is in sync with the one in xserver-nodm-init.bb
USERADD_PACKAGES = "${PN}"
USERADD_PARAM_${PN} = "--create-home \
--groups video,tty,audio \
diff --git a/meta/recipes-connectivity/connman/connman_0.79.bb b/meta/recipes-connectivity/connman/connman_0.79.bb
index ec3d147d84..898fb11f07 100644
--- a/meta/recipes-connectivity/connman/connman_0.79.bb
+++ b/meta/recipes-connectivity/connman/connman_0.79.bb
@@ -11,4 +11,4 @@ SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git \
file://test-set-ipv6-method-api-fix.patch \
file://connman"
S = "${WORKDIR}/git"
-PR = "r5"
+PR = "${INC_PR}.0"
diff --git a/meta/recipes-graphics/x11-common/xserver-nodm-init.bb b/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
index 1b9526104c..8fca05613c 100644
--- a/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
+++ b/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
@@ -30,6 +30,8 @@ INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
# Use fixed Xusername of xuser for now, this will need to be
# fixed if the Xusername changes from xuser
+# IMPORTANT: because xuser is shared with connman, please make sure the
+# USERADD_PARAM is in sync with the one in connman.inc
USERADD_PACKAGES = "${PN}"
USERADD_PARAM_${PN} = "--create-home \
--groups video,tty,audio \