summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-05-07 00:08:30 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-10 09:51:55 +0100
commitadf9f92e2f8f6cc3deba72a194ded85e160ad9e3 (patch)
tree6a2f81b795610939ade7af4ae1b6ad531845b706
parent9187ac0173f26c6a621229ff588f495e9967e665 (diff)
downloadopenembedded-core-adf9f92e2f8f6cc3deba72a194ded85e160ad9e3.tar.gz
linux-yocto: error if meta data not present
There are valid reasons to build repositories without meta data present and there are times when this is an error. This change adds sanity tests to the build process to detect missing meta data and throw an informative error message. Sanity checking is only triggered from recipes (linux-yocto) that always require meta data to be present. Other recipes are not impacted and can auto-generate meta data as required. Without this change the build process suceeds, but incorrect meta data will be used (with no user knowledge), which is not the desired behaviour. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta/classes/kernel-yocto.bbclass5
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_git.bb4
3 files changed, 8 insertions, 3 deletions
diff --git a/meta/classes/kernel-yocto.bbclass b/meta/classes/kernel-yocto.bbclass
index ffc0b4c6ee..818a07e219 100644
--- a/meta/classes/kernel-yocto.bbclass
+++ b/meta/classes/kernel-yocto.bbclass
@@ -13,7 +13,10 @@ do_patch() {
fi
# simply ensures that a branch of the right name has been created
- createme ${ARCH} ${kbranch} ${defconfig}
+ if [ -n "${YOCTO_KERNEL_META_DATA}" ]; then
+ createme_flags="--disable-meta-gen"
+ fi
+ createme ${createme_flags} ${ARCH} ${kbranch} ${defconfig}
if [ $? -ne 0 ]; then
echo "ERROR. Could not create ${kbranch}"
exit 1
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index 820765e8a2..c808e175f0 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d8
DEPENDS = "git-native guilt-native"
-SRCREV = "c5896a60acc61f8966cfee3bb241ff564610cea4"
+SRCREV = "ab49d8e48b7e66d1b4f924385d65d062d25e44f7"
PR = r10
PV = "0.1+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_git.bb b/meta/recipes-kernel/linux/linux-yocto_git.bb
index d4f2ecee63..f54033d57f 100644
--- a/meta/recipes-kernel/linux/linux-yocto_git.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_git.bb
@@ -22,7 +22,7 @@ SRCREV_machine_qemux86-64 = "b906f358fd404a1e74a961f25079274e0d933ee1"
SRCREV_machine = "b906f358fd404a1e74a961f25079274e0d933ee1"
SRCREV_meta = "ecab1e2bc12a8b0c4d064a00acc3260f6e8528c5"
-PR = "r17"
+PR = "r18"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRCREV_FORMAT = "meta_machine"
@@ -36,6 +36,8 @@ KERNEL_FEATURES="features/netfilter"
KERNEL_FEATURES_append_qemux86=" cfg/sound"
KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
+YOCTO_KERNEL_META_DATA=t
+
# extra tasks
addtask kernel_link_vmlinux after do_compile before do_install
addtask validate_branches before do_patch after do_kernel_checkout