summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Felsch <m.felsch@pengutronix.de>2023-11-28 23:47:44 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-02 17:15:30 +0000
commit915f8307b063e17ddadd5dface83578b8ad254e2 (patch)
treec4d10d109e5acd43cf05c369521fe03c8395d593
parent8c53a58ac6790aa2296f14a7a5d0d67ede1055da (diff)
downloadopenembedded-core-915f8307b063e17ddadd5dface83578b8ad254e2.tar.gz
json-c: fix icecc compilation
Skip -Werror to make it possible to compile this recipe with ICECC else all fallthrough comments will be removed since we pre-process the files on the host before sending them to the compile nodes which then cause errors because of default -Werror switch. Fixes: caf64f85b5c5 ("json-c: update 0.13.1 - > 0.14") Signed-off-by: Marco Felsch <m.felsch@pengutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.17.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.17.bb b/meta/recipes-devtools/json-c/json-c_0.17.bb
index f4b7a32cea..20bcece768 100644
--- a/meta/recipes-devtools/json-c/json-c_0.17.bb
+++ b/meta/recipes-devtools/json-c/json-c_0.17.bb
@@ -17,6 +17,9 @@ UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+)-\d+"
RPROVIDES:${PN} = "libjson"
+# Required for ICECC builds
+EXTRA_OECMAKE = "-DDISABLE_WERROR=ON"
+
inherit cmake ptest
do_install_ptest() {