summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-08-10 23:31:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-15 08:14:32 +0100
commit7b84fe344a2067b63d0c222fbc68d5916fa7903f (patch)
tree4838799c8de2cbf31c60bebef402c6e970eaa8ba
parent5a0a7da85a3acfd4a20a07478eabefdab60f313a (diff)
downloadopenembedded-core-7b84fe344a2067b63d0c222fbc68d5916fa7903f.tar.gz
systemd-boot: Fix build on musl
systemd efi.h defines wchar_t from compiler provided __WCHAR_TYPE__ therefore we do not want it to come from alltypes.h in musl case which otherwise will end up with conflicting definitions of wchar_t, defining __DEFINED_wchar_t ensures that alltypes.h does not provide it Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd-boot_254.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd-boot_254.bb b/meta/recipes-core/systemd/systemd-boot_254.bb
index 5d69cf83ab..6240ee9339 100644
--- a/meta/recipes-core/systemd/systemd-boot_254.bb
+++ b/meta/recipes-core/systemd/systemd-boot_254.bb
@@ -49,6 +49,8 @@ RDEPENDS:${PN} += "virtual-systemd-bootconf"
# Imported from the old gummiboot recipe
TUNE_CCARGS:remove = "-mfpmath=sse"
+CFLAGS:append:libc-musl = " -D__DEFINED_wchar_t"
+
COMPATIBLE_HOST = "(aarch64.*|arm.*|x86_64.*|i.86.*)-linux"
COMPATIBLE_HOST:x86-x32 = "null"