summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleh Matiusha <omatiush@cisco.com>2024-03-27 17:16:16 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-04 14:02:24 +0100
commit7b072b46bd0d0442066189ecf098b56e50ea77b1 (patch)
tree535d9f108334cc9d1626f359f2b93fce149228cf
parent30f4471ddced07929524b12ee5567521d51de033 (diff)
downloadopenembedded-core-7b072b46bd0d0442066189ecf098b56e50ea77b1.tar.gz
gmp: improve reproducibility
nativesdk-gmp package contains host references in output packages. remove them. Signed-off-by: Oleh Matiusha <omatiush@cisco.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/gmp/gmp_6.3.0.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-support/gmp/gmp_6.3.0.bb b/meta/recipes-support/gmp/gmp_6.3.0.bb
index 3dbcd68b5c..fd4aec92fd 100644
--- a/meta/recipes-support/gmp/gmp_6.3.0.bb
+++ b/meta/recipes-support/gmp/gmp_6.3.0.bb
@@ -29,13 +29,21 @@ do_install:append() {
oe_multilib_header gmp.h
}
-do_install:prepend:class-target() {
+fix_absolute_paths () {
sed -i \
-e "s|--sysroot=${STAGING_DIR_HOST}||g" \
-e "s|${DEBUG_PREFIX_MAP}||g" \
${B}/gmp.h
}
+do_install:prepend:class-target() {
+ fix_absolute_paths
+}
+
+do_install:prepend:class-nativesdk() {
+ fix_absolute_paths
+}
+
SSTATE_SCAN_FILES += "gmp.h"
# Doesn't compile in MIPS16e mode due to use of hand-written