summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-02-02 14:23:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-03 21:41:19 +0000
commit785c39701ea17e6a539709b9ae905f7b0667bceb (patch)
tree5fc47fa8db788d0954310b14cb7105d191589a19
parent104f0ff88166ccd10adaaf78705d91b0fa26be24 (diff)
downloadopenembedded-core-785c39701ea17e6a539709b9ae905f7b0667bceb.tar.gz
rpm: override curl executable search with just 'curl'
rpm is searching for curl executable at do_configure time and result is non-deterministic, depending on whether curl is in native sysroot or not: https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20240201-8dcic6ea/packages/diff-html/ Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.19.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.19.1.bb b/meta/recipes-devtools/rpm/rpm_4.19.1.bb
index af11dec5ef..086f100229 100644
--- a/meta/recipes-devtools/rpm/rpm_4.19.1.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.19.1.bb
@@ -51,6 +51,7 @@ S = "${WORKDIR}/git"
DEPENDS = "lua libgcrypt file popt xz bzip2 elfutils python3 sqlite3 zstd"
DEPENDS:append:class-native = " file-replacement-native bzip2-replacement-native"
+EXTRA_OECMAKE:append = " -D__CURL:FILEPATH=curl"
EXTRA_OECMAKE:append:libc-musl = " -DENABLE_NLS=OFF -DENABLE_OPENMP=OFF"
# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs