summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-12-13 12:11:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-18 19:45:39 +0000
commit761a17b7beab248056b69b9c3d84b1ddc4d2082d (patch)
treeb85ab2febe757bcf9c33ff9dbfe3c5c5d5149199
parent402254a5f841520b132508c21465111d33b6eb1a (diff)
downloadopenembedded-core-761a17b7beab248056b69b9c3d84b1ddc4d2082d.tar.gz
ghostscript: update 9.56.1 -> 10.0.0
Drop --without-jbig2dec as it is now required by pdf support and jbig2dec library is in ghostscript's source tree. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript/cross-compile.patch40
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript/do-not-check-local-libpng-source.patch (renamed from meta/recipes-extended/ghostscript/files/do-not-check-local-libpng-source.patch)8
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_10.0.0.bb (renamed from meta/recipes-extended/ghostscript/ghostscript_9.56.1.bb)5
3 files changed, 47 insertions, 6 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript/cross-compile.patch b/meta/recipes-extended/ghostscript/ghostscript/cross-compile.patch
new file mode 100644
index 0000000000..ba62820df1
--- /dev/null
+++ b/meta/recipes-extended/ghostscript/ghostscript/cross-compile.patch
@@ -0,0 +1,40 @@
+From 4c3575346b9c7d394ebc73b4e5fabebadd8877ec Mon Sep 17 00:00:00 2001
+From: Chris Liddell <chris.liddell@artifex.com>
+Date: Thu, 24 Nov 2022 16:33:47 +0000
+Subject: [PATCH] Fix a little bitrot in the cross-compiling logic
+
+Removing the option to disable FAPI meant configuring for cross compiling would
+fail because the option being passed to the sub-call to configure would include
+an unknown command line option.
+
+Upstream-Status: Backport [https://git.ghostscript.com/?p=ghostpdl.git;a=patch;f=configure.ac;h=4c3575346b9c7d394ebc73b4e5fabebadd8877ec]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index d5c68c4b3..738eb10a9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -138,7 +138,7 @@ if test x"$host" != x"$build" ; then
+ echo $AUXFLAGS_MAK_LINE07 >> $AUXFLAGS_MAK.in
+
+ AC_MSG_NOTICE([Begin recursive call to configure script (for auxiliary tools)])
+- "$absolute_source_path/configure" CC="$CCAUX" CFLAGS="$CFLAGSAUX" CPPFLAGS="$CPPFLAGSAUX" LDFLAGS="$LDFLAGSAUX" CCAUX= CFLAGSAUX= CFLAGSAUX= MAKEFILE=$AUXFLAGS_MAK --host=$build --build=$build --enable-auxtools_only --disable-hidden-visibility --with-local-zlib --without-libtiff --disable-contrib --disable-fontconfig --disable-dbus --disable-freetype --disable-fapi --disable-cups --disable-openjpeg --disable-gtk --with-libiconv=no --without-libidn --without-libpaper --without-pdftoraster --without-ijs --without-jbig2dec --without-x --with-drivers=""
++ "$absolute_source_path/configure" CC="$CCAUX" CFLAGS="$CFLAGSAUX" CPPFLAGS="$CPPFLAGSAUX" LDFLAGS="$LDFLAGSAUX" CCAUX= CFLAGSAUX= CFLAGSAUX= MAKEFILE=$AUXFLAGS_MAK --host=$build --build=$build --enable-auxtools_only --disable-hidden-visibility --with-local-zlib --without-libtiff --disable-contrib --disable-fontconfig --disable-dbus --disable-freetype --disable-cups --disable-openjpeg --disable-gtk --with-libiconv=no --without-libidn --without-libpaper --without-pdftoraster --without-ijs --without-jbig2dec --without-x --with-drivers=""
+ status=$?
+ cp config.log "$olddir/configaux.log"
+ if test $status -eq 0 ; then
+@@ -2530,7 +2530,7 @@ PDF=
+ PDF_MAK="\$(GLSRCDIR)\$(D)stub.mak"
+ PDFROMFS_MAK="\$(GLSRCDIR)\$(D)stub.mak"
+
+-if test x"$with_pdf" != x"no" ; then
++if test x"$with_pdf" != x"no" -a x"$enable_auxtools_only" != x"yes" ; then
+
+ if test x"$JBIG2_DECODER" = x""; then
+ AC_MSG_ERROR([No JBIG2 decoder available, required for PDF support])
+--
+2.25.1
+
diff --git a/meta/recipes-extended/ghostscript/files/do-not-check-local-libpng-source.patch b/meta/recipes-extended/ghostscript/ghostscript/do-not-check-local-libpng-source.patch
index a9afb9948c..13e71c824f 100644
--- a/meta/recipes-extended/ghostscript/files/do-not-check-local-libpng-source.patch
+++ b/meta/recipes-extended/ghostscript/ghostscript/do-not-check-local-libpng-source.patch
@@ -1,4 +1,4 @@
-From 2adaa7366064a8f18af864eda74e52877a89620c Mon Sep 17 00:00:00 2001
+From 108a7d3f79af8c669af129bd87401402e76edfa9 Mon Sep 17 00:00:00 2001
From: Hongxu Jia <hongxu.jia@windriver.com>
Date: Mon, 18 Jan 2016 01:00:30 -0500
Subject: [PATCH] configure.ac: do not check local png source
@@ -17,12 +17,12 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
-index 698abd3..e65ac8b 100644
+index bb57825..389c473 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1241,7 +1241,7 @@ else
+@@ -1441,7 +1441,7 @@ else
PNGDEVS=''
- PNGDEVS_ALL='png48 png16m pnggray pngmono pngmonod png256 png16 pngalpha'
+ PNGDEVS_ALL='png48 png16m pnggray pngmono pngmonod png256 png16 pngalpha png16malpha'
AC_MSG_CHECKING([for local png library source])
- if test -f $srcdir/libpng/pngread.c; then
+ if false; then
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.56.1.bb b/meta/recipes-extended/ghostscript/ghostscript_10.0.0.bb
index e71a6cc0d3..56a93632e2 100644
--- a/meta/recipes-extended/ghostscript/ghostscript_9.56.1.bb
+++ b/meta/recipes-extended/ghostscript/ghostscript_10.0.0.bb
@@ -33,6 +33,7 @@ SRC_URI_BASE = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/d
file://do-not-check-local-libpng-source.patch \
file://avoid-host-contamination.patch \
file://mkdir-p.patch \
+ file://cross-compile.patch \
"
SRC_URI = "${SRC_URI_BASE} \
@@ -44,7 +45,7 @@ SRC_URI:class-native = "${SRC_URI_BASE} \
file://base-genht.c-add-a-preprocessor-define-to-allow-fope.patch \
"
-SRC_URI[sha256sum] = "1598b9a38659cce8448d42a73054b2f9cbfcc40a9b97eeec5f22d4d6cd1de8e6"
+SRC_URI[sha256sum] = "a57764d70caf85e2fc0b0f59b83b92e25775631714dcdb97cc6e0cea414bb5a3"
# Put something like
#
@@ -72,7 +73,7 @@ EXTRA_OECONF:append:mipsarcho32 = " --with-large_color_index=0"
# Explicity disable libtiff, fontconfig,
# freetype, cups for ghostscript-native
EXTRA_OECONF:class-native = "--without-x --with-system-libtiff=no \
- --without-jbig2dec --without-libpaper \
+ --without-libpaper \
--with-fontpath=${datadir}/fonts \
--without-libidn --disable-fontconfig \
--enable-freetype --disable-cups "