summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-05-18 17:08:20 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-22 10:53:44 +0100
commit5fc09287ec8ca4332614eaa6b0dd5aabf10f6a31 (patch)
tree190f535ef7cf1a46d6b2d41e95bdc42ed3da2f9b
parent09476b2be0c8a155dc6494442cc3caca97782595 (diff)
downloadopenembedded-core-5fc09287ec8ca4332614eaa6b0dd5aabf10f6a31.tar.gz
python3-gitdb: remove python3-async dependency
The dependency on the async module was removed back in 0.6.0 (November 2014). Whilst here, also merge the bb/inc and stop using PYTHON_PN, as we only support Python 3. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-devtools/python/python-gitdb.inc23
-rw-r--r--meta/recipes-devtools/python/python3-gitdb_4.0.10.bb23
2 files changed, 21 insertions, 25 deletions
diff --git a/meta/recipes-devtools/python/python-gitdb.inc b/meta/recipes-devtools/python/python-gitdb.inc
deleted file mode 100644
index d92d6453d8..0000000000
--- a/meta/recipes-devtools/python/python-gitdb.inc
+++ /dev/null
@@ -1,23 +0,0 @@
-SUMMARY = "A pure-Python git object database"
-HOMEPAGE = "http://github.com/gitpython-developers/gitdb"
-SECTION = "devel/python"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=59e5ecb13339a936eedf83282eaf4528"
-
-inherit pypi
-
-PYPI_PACKAGE = "gitdb"
-
-SRC_URI[sha256sum] = "6eb990b69df4e15bad899ea868dc46572c3f75339735663b81de79b06f17eb9a"
-
-DEPENDS = "${PYTHON_PN}-async ${PYTHON_PN}-setuptools-native ${PYTHON_PN}-smmap"
-
-RDEPENDS:${PN} += "${PYTHON_PN}-async \
- ${PYTHON_PN}-compression \
- ${PYTHON_PN}-crypt \
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-mmap \
- ${PYTHON_PN}-shell \
- ${PYTHON_PN}-smmap \
-"
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/python/python3-gitdb_4.0.10.bb b/meta/recipes-devtools/python/python3-gitdb_4.0.10.bb
index 2dcd9c8aff..3a430c30f0 100644
--- a/meta/recipes-devtools/python/python3-gitdb_4.0.10.bb
+++ b/meta/recipes-devtools/python/python3-gitdb_4.0.10.bb
@@ -1,3 +1,22 @@
-inherit setuptools3
-require python-gitdb.inc
+SUMMARY = "A pure-Python git object database"
+HOMEPAGE = "http://github.com/gitpython-developers/gitdb"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=59e5ecb13339a936eedf83282eaf4528"
+DEPENDS = "python3-smmap"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "gitdb"
+
+SRC_URI[sha256sum] = "6eb990b69df4e15bad899ea868dc46572c3f75339735663b81de79b06f17eb9a"
+
+RDEPENDS:${PN} += "python3-compression \
+ python3-crypt \
+ python3-io \
+ python3-mmap \
+ python3-shell \
+ python3-smmap \
+"
+BBCLASSEXTEND = "native nativesdk"