summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-12 11:18:59 +0000
committerRichard Purdie <richard@openedhand.com>2008-08-12 11:18:59 +0000
commit5bbdd31d82535586f5b1e1984c86a718b16b4380 (patch)
treee40e5d3221eeafb10282eb6a369fe2dabb6dbbec
parent67e520f96faaa1880b5992516e36fe7377887fea (diff)
downloadopenembedded-core-5bbdd31d82535586f5b1e1984c86a718b16b4380.tar.gz
Add moblin-proto, drop ununused clutter-box2d patch
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5056 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/clutter/clutter-box2d/clutter08.patch13
-rw-r--r--meta/packages/clutter/moblin-proto/fix.patch44
-rw-r--r--meta/packages/clutter/moblin-proto_git.bb14
3 files changed, 58 insertions, 13 deletions
diff --git a/meta/packages/clutter/clutter-box2d/clutter08.patch b/meta/packages/clutter/clutter-box2d/clutter08.patch
deleted file mode 100644
index bf830a79c8..0000000000
--- a/meta/packages/clutter/clutter-box2d/clutter08.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: clutter-box2d/configure.ac
-===================================================================
---- clutter-box2d.orig/configure.ac 2008-07-16 10:09:40.000000000 +0100
-+++ clutter-box2d/configure.ac 2008-07-16 10:09:51.000000000 +0100
-@@ -70,7 +70,7 @@
- dnl ========================================================================
-
-
--pkg_modules="clutter-0.7 >= 0.7.0"
-+pkg_modules="clutter-0.8 >= 0.8.0"
- PKG_CHECK_MODULES(DEPS, [$pkg_modules])
-
- if test "x$GCC" = "xyes"; then
diff --git a/meta/packages/clutter/moblin-proto/fix.patch b/meta/packages/clutter/moblin-proto/fix.patch
new file mode 100644
index 0000000000..802b8c4b6c
--- /dev/null
+++ b/meta/packages/clutter/moblin-proto/fix.patch
@@ -0,0 +1,44 @@
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile 2008-08-11 22:49:48.000000000 +0100
++++ git/Makefile 2008-08-12 12:16:52.000000000 +0100
+@@ -15,7 +15,7 @@
+
+ SCP_DESTINATION=pug.vpn:tmp
+
+-BINARY=$(shell basename `pwd`)#
++BINARY=moblin-proto
+ PACKAGE=../$(BINARY).tar.bz2 # you can use both .gz and .bz2 as extension here
+
+ #CFLAGS= -Wall -I /home/pippin/src/clutter-box2d/clutter-box2d
+@@ -61,7 +61,7 @@
+ %.o: %.c $(HFILES)
+ $(CC) -g $(CFLAGS) $(INCS) -c $< -o$@
+ $(BINARY): $(OBJECTS)
+- $(CC) -o $@ $(OBJECTS) $(LIBS)
++ $(CXX) -o $@ $(OBJECTS) $(LIBS)
+
+ #$(BINARY): $(CFILES)
+ # $(LD) $(CFLAGS) $(INCS) $(CFILES) $(LIBS) -o $@
+Index: git/moblin-desktop.c
+===================================================================
+--- git.orig/moblin-desktop.c 2008-08-11 22:49:49.000000000 +0100
++++ git/moblin-desktop.c 2008-08-12 12:14:44.000000000 +0100
+@@ -620,17 +620,10 @@
+
+ attach_reactivate_on_press (old_app);
+
+-<<<<<<< HEAD:moblin-desktop.c
+ shuttle = clutter_group_new ();
+ clutter_group_add (CLUTTER_GROUP(desktop->mainstuff), shuttle);
+ copy_geometry (desktop->middle, shuttle);
+ clutter_actor_reparent (old_app, shuttle);
+-=======
+- box = clutter_group_new ();
+- clutter_group_add (CLUTTER_GROUP(desktop->stage), box);
+- copy_geometry (desktop->middle, box);
+- clutter_actor_reparent (old_app, box);
+->>>>>>> Removed now unneeded forcible shows of apps.:moblin-desktop.c
+
+ {
+ gint x, y;
diff --git a/meta/packages/clutter/moblin-proto_git.bb b/meta/packages/clutter/moblin-proto_git.bb
new file mode 100644
index 0000000000..00b5b5e3f3
--- /dev/null
+++ b/meta/packages/clutter/moblin-proto_git.bb
@@ -0,0 +1,14 @@
+
+DEPENDS = "clutter-box2d"
+
+PV = "0.0+git${SRCREV}"
+
+SRC_URI = "git://moblin.org/repos/users/pippin/prototype.git/;protocol=http \
+ file://fix.patch;patch=1"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ install -d ${D}${bindir}
+ install ${S}/moblin-proto ${D}${bindir}
+}