summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-01-31 13:54:06 +0000
committerAnuj Mittal <anuj.mittal@intel.com>2022-02-04 11:19:55 +0800
commit593a10c37f7928ce4714dd16bd26dc0cb56446e9 (patch)
tree3fa2299296bbaaacfed8bddc2d52b9e5a3c6b5ee
parent61dcaeda02fe1136610f1cf4d4ec271f16dacfcf (diff)
downloadopenembedded-core-593a10c37f7928ce4714dd16bd26dc0cb56446e9.tar.gz
core-image-sato-sdk: allocate more memory when in qemu
Compiling code is memory-intensive, especially kernel modules like the SystemTap probes, so give the VM 768MB of RAM. Using 1GB appears to cause PCI error, interestingly. Hopefully this solves the intermittent failures caused by OOMs during the SystemTap test. [ YOCTO #14673 ] Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 50ff1f018a670c963e1979dee76ebd696153b4c1) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--meta/recipes-sato/images/core-image-sato-sdk.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-sato/images/core-image-sato-sdk.bb b/meta/recipes-sato/images/core-image-sato-sdk.bb
index b52de0def0..afab473b52 100644
--- a/meta/recipes-sato/images/core-image-sato-sdk.bb
+++ b/meta/recipes-sato/images/core-image-sato-sdk.bb
@@ -10,3 +10,6 @@ IMAGE_FEATURES += "dev-pkgs tools-sdk \
IMAGE_INSTALL += "kernel-devsrc"
+# Compiling stuff, specifically SystemTap probes, can require lots of memory
+# See https://bugzilla.yoctoproject.org/show_bug.cgi?id=14673
+QB_MEM = "-m 768"