summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-12-29 11:09:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-31 17:06:19 +0000
commit44441c727a5301ab99ab8b4d8b8b1f61f0a810af (patch)
tree01531f5400baac54aabc13f428b38dbef4cc7393
parent34f1121ba9684b1ab978438db2b16c1e42ea5973 (diff)
downloadopenembedded-core-44441c727a5301ab99ab8b4d8b8b1f61f0a810af.tar.gz
cargo: Do not use open64 on musl anymore
The same rust getrandom patch is needed for cargo on target as well as it uses the same crate Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rust/cargo_1.66.0.bb5
-rw-r--r--meta/recipes-devtools/rust/files/getrandom-open64.patch (renamed from meta/recipes-devtools/rust/rust/getrandom-open64.patch)0
2 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rust/cargo_1.66.0.bb b/meta/recipes-devtools/rust/cargo_1.66.0.bb
index 37e0123ee3..f45f8f1e12 100644
--- a/meta/recipes-devtools/rust/cargo_1.66.0.bb
+++ b/meta/recipes-devtools/rust/cargo_1.66.0.bb
@@ -14,7 +14,10 @@ LIC_FILES_CHKSUM = " \
require rust-source.inc
require rust-snapshot.inc
-SRC_URI:append:class-target = " file://crossbeam_atomic.patch;patchdir=${RUSTSRC}"
+SRC_URI:append:class-target = "\
+ file://crossbeam_atomic.patch;patchdir=${RUSTSRC} \
+ file://getrandom-open64.patch;patchdir=${RUSTSRC} \
+"
# Used by crossbeam_atomic.patch
export TARGET_VENDOR
diff --git a/meta/recipes-devtools/rust/rust/getrandom-open64.patch b/meta/recipes-devtools/rust/files/getrandom-open64.patch
index 6fc981e2aa..6fc981e2aa 100644
--- a/meta/recipes-devtools/rust/rust/getrandom-open64.patch
+++ b/meta/recipes-devtools/rust/files/getrandom-open64.patch