summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2022-12-28 15:23:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-28 23:53:23 +0000
commit39402790724014a39b265ee1978396a0514fdc98 (patch)
tree77eb3e96b6509e27a32a3931898e61cf24376c9c
parentc874ef5eafb88d361b96e014739d7a3a640536d9 (diff)
downloadopenembedded-core-39402790724014a39b265ee1978396a0514fdc98.tar.gz
cargo: Include crossbeam-utils patch
We need patched crossbeam-utils in cargo as well as rust, move cargo alongside rust so they can both use the same patch. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rust/cargo_1.66.0.bb (renamed from meta/recipes-devtools/cargo/cargo_1.66.0.bb)9
-rw-r--r--meta/recipes-devtools/rust/files/crossbeam_atomic.patch (renamed from meta/recipes-devtools/rust/rust/crossbeam_atomic.patch)0
2 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-devtools/cargo/cargo_1.66.0.bb b/meta/recipes-devtools/rust/cargo_1.66.0.bb
index fe8049b68c..f00c67bef5 100644
--- a/meta/recipes-devtools/cargo/cargo_1.66.0.bb
+++ b/meta/recipes-devtools/rust/cargo_1.66.0.bb
@@ -11,8 +11,13 @@ LIC_FILES_CHKSUM = " \
file://LICENSE-THIRD-PARTY;md5=f257ad009884cb88a3a87d6920e7180a \
"
-require recipes-devtools/rust/rust-source.inc
-require recipes-devtools/rust/rust-snapshot.inc
+require rust-source.inc
+require rust-snapshot.inc
+
+SRC_URI:append:class-target = " file://crossbeam_atomic.patch;patchdir=${RUSTSRC}"
+
+# Used by crossbeam_atomic.patch
+export TARGET_VENDOR
S = "${RUSTSRC}/src/tools/cargo"
CARGO_VENDORING_DIRECTORY = "${RUSTSRC}/vendor"
diff --git a/meta/recipes-devtools/rust/rust/crossbeam_atomic.patch b/meta/recipes-devtools/rust/files/crossbeam_atomic.patch
index b24ac439c6..b24ac439c6 100644
--- a/meta/recipes-devtools/rust/rust/crossbeam_atomic.patch
+++ b/meta/recipes-devtools/rust/files/crossbeam_atomic.patch