summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-10 17:11:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-10 17:12:22 +0100
commit162f0c5361f951111d8b7dc5aeb85ccd323cae30 (patch)
treeb5ac670a76270faa13c165f6ee365bb661a00598
parentfe983dcff611df2a4fef0d094b130cdf04c0728d (diff)
downloadopenembedded-core-162f0c5361f951111d8b7dc5aeb85ccd323cae30.tar.gz
Revert "linux-yocto: Allow bbappend files to add to COMPATIBLE_MACHINE to fix errors"
There are better ways to handle this problem. This reverts commit fe983dcff611df2a4fef0d094b130cdf04c0728d.
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_git.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_git.bb b/meta/recipes-kernel/linux/linux-yocto_git.bb
index 62b128ee37..f54033d57f 100644
--- a/meta/recipes-kernel/linux/linux-yocto_git.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_git.bb
@@ -28,8 +28,7 @@ SRCREV_FORMAT = "meta_machine"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
-EXTRA_COMPATMACHS ??= ""
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64${EXTRA_COMPATMACHS})"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
# Functionality flags
KERNEL_REVISION_CHECKING ?= "t"