aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-networking/python/python3-ldap_3.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-networking/python/python3-ldap_3.4.4.bb')
-rw-r--r--meta-python/recipes-networking/python/python3-ldap_3.4.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-networking/python/python3-ldap_3.4.4.bb b/meta-python/recipes-networking/python/python3-ldap_3.4.4.bb
new file mode 100644
index 0000000000..6caf5f37ce
--- /dev/null
+++ b/meta-python/recipes-networking/python/python3-ldap_3.4.4.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Provides a wrapper in Python to LDAP"
+DESCRIPTION = "This module provides access to the LDAP \
+(Lightweight Directory Access Protocol) through Python operations \
+instead of C API. The module mainly acts as a wrapper for the \
+OpenLDAP 2.x libraries. Errors will appear as exceptions."
+HOMEPAGE = "http://www.python-ldap.org/"
+LICENSE = "PSF-2.0"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
+
+DEPENDS = "python3 openldap cyrus-sasl"
+
+PYPI_PACKAGE = "python-ldap"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "7edb0accec4e037797705f3a05cbf36a9fde50d08c8f67f2aef99a2628fab828"
+
+do_configure:prepend() {
+ sed -i -e 's:^library_dirs =.*::' \
+ -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' \
+ -e 's/= ldap_r/= ldap/g' ${S}/setup.cfg
+}
+
+RDEPENDS:${PN} = " \
+ python3-pprint \
+ python3-pyasn1 \
+ python3-pyasn1-modules \
+ python3-threading \
+ python3-unittest \
+"