aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-pyparted
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-pyparted')
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb10
-rw-r--r--meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.1.bb10
-rw-r--r--meta-python/recipes-extended/python-pyparted/python3-pyparted_3.12.0.bb (renamed from meta-python/recipes-extended/python-pyparted/python-pyparted.inc)21
3 files changed, 13 insertions, 28 deletions
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb
deleted file mode 100644
index 7d00fd7d93..0000000000
--- a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require python-pyparted.inc
-
-PV = "3.10.7+git${SRCPV}"
-
-inherit distutils
-
-RDEPENDS_${PN} += "python-stringold python-codecs python-math python-subprocess"
-RDEPENDS_${PN}_class-native = ""
-
-BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.1.bb b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.1.bb
deleted file mode 100644
index 4d6f97b59e..0000000000
--- a/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.1.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require python-pyparted.inc
-
-PV = "3.10.7+git${SRCPV}"
-
-inherit distutils3
-
-RDEPENDS_${PN} += "python3-stringold python3-codecs python3-math"
-RDEPENDS_${PN}_class-native = ""
-
-BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.12.0.bb
index a0ec02817a..7a0d3987d2 100644
--- a/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
+++ b/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.12.0.bb
@@ -3,20 +3,25 @@ an interface to libparted, the GNU parted library for disk partitioning and \
filesystem manipulation."
SUMMARY = "Python bindings for libparted"
HOMEPAGE = "https://github.com/rhinstaller/pyparted"
-LICENSE = "GPL-2.0+"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "\
file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \
"
-DEPENDS += "parted"
-# upstream only publishes releases in github archives which are discouraged
-SRCREV = "1fdb15120f35f5da1dc7ec116522f0c796a8376a"
-SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https"
+SRC_URI[sha256sum] = "da985e116beb733371feb605b174db9eec8bd0eedffc8f739f8e603f51b521e7"
+
+inherit pkgconfig pypi setuptools3
-S = "${WORKDIR}/git"
+DEPENDS += "parted"
-RDEPENDS_${PN}_class-target += " \
+RDEPENDS:${PN}:class-target += " \
parted (>= 2.3) \
+ python3-codecs \
+ python3-math \
+ python3-numbers \
+ python3-stringold \
"
-RDEPENDS_${PN}_class-native = ""
+RDEPENDS:${PN}:class-native = ""
+
+BBCLASSEXTEND = "native"