aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pluggy.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-pluggy_0.6.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pluggy_0.6.0.bb2
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pluggy.inc b/meta-python/recipes-devtools/python/python-pluggy.inc
new file mode 100644
index 0000000000..320359aa64
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pluggy.inc
@@ -0,0 +1,9 @@
+SUMMARY = "Plugin and hook calling mechanisms for python"
+HOMEPAGE = "https://github.com/pytest-dev/pluggy"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=338dad807ed9337bfaeb9979c3bfe20f"
+
+SRC_URI[md5sum] = "ffdde7c3a5ba9a440404570366ffb6d5"
+SRC_URI[sha256sum] = "7f8ae7f5bdf75671a718d2daf0a64b7885f74510bcd98b1a0bb420eb9a9d0cff"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-pluggy_0.6.0.bb b/meta-python/recipes-devtools/python/python-pluggy_0.6.0.bb
new file mode 100644
index 0000000000..edcd4f512f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pluggy_0.6.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-pluggy.inc
diff --git a/meta-python/recipes-devtools/python/python3-pluggy_0.6.0.bb b/meta-python/recipes-devtools/python/python3-pluggy_0.6.0.bb
new file mode 100644
index 0000000000..941e8e3d8c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pluggy_0.6.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pluggy.inc