aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest-cov_5.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest-cov_5.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-cov_5.0.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-cov_5.0.0.bb b/meta-python/recipes-devtools/python/python3-pytest-cov_5.0.0.bb
new file mode 100644
index 0000000000..e3e4affb9d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-cov_5.0.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Pytest plugin for measuring coverage."
+HOMEPAGE = "https://github.com/pytest-dev/pytest-cov"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE;md5=cbc4e25353c748c817db2daffe605e43 \
+"
+
+SRC_URI[sha256sum] = "5837b58e9f6ebd335b0f8060eecce69b662415b16dc503883a02f45dfeb14857"
+
+inherit pypi setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+RDEPENDS:${PN} += "python3-coverage python3-pytest"
+
+BBCLASSEXTEND = "native nativesdk"