aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
new file mode 100644
index 0000000000..78662fe3cd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.11.1.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Seamless operability between C++11 and Python"
+HOMEPAGE = "https://github.com/pybind/pybind11"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
+DEPENDS = "\
+ python3-cmake-native \
+ python3-ninja-native \
+"
+
+SRCREV = "8a099e44b3d5f85b20f05828d919d2332a8de841"
+SRC_URI = "\
+ git://github.com/pybind/pybind11.git;branch=stable;protocol=https \
+ file://0001-Do-not-strip-binaries.patch \
+"
+
+S = "${WORKDIR}/git"
+
+inherit cmake python_setuptools_build_meta
+
+EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
+
+do_configure:append() {
+ cmake_do_configure
+}
+
+do_compile:append() {
+ cmake_do_compile
+}
+
+do_install:append() {
+ cmake_do_install
+}
+
+BBCLASSEXTEND = "native nativesdk"