aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-mock_5.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-mock_5.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-mock_5.1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-mock_5.1.0.bb b/meta-python/recipes-devtools/python/python3-mock_5.1.0.bb
new file mode 100644
index 0000000000..d9ecb9d4c8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-mock_5.1.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A Python Mocking and Patching Library for Testing"
+HOMEPAGE = "https://pypi.python.org/pypi/mock"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=de9dfbf780446b18aab11f00baaf5b7e"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-cmd2 \
+ python3-mccabe \
+ python3-pep8 \
+ python3-prettytable \
+ python3-pyflakes \
+ python3-pyparsing \
+ python3-unittest \
+"
+
+SRC_URI[sha256sum] = "5e96aad5ccda4718e0a229ed94b2024df75cc2d55575ba5762d31f5767b8767d"