aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-jsonrpcclient_4.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-jsonrpcclient_4.0.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonrpcclient_4.0.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsonrpcclient_4.0.3.bb b/meta-python/recipes-devtools/python/python3-jsonrpcclient_4.0.3.bb
new file mode 100644
index 0000000000..459726199e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonrpcclient_4.0.3.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Generate JSON-RPC requests and parse responses in Python"
+HOMEPAGE = "https://github.com/explodinglabs/jsonrpcclient"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=10f3d7679914df805c98fb351172e677"
+
+SRCREV = "e5dd11736925a9a8e463fc9420eab95235f181e3"
+SRC_URI = "git://github.com/explodinglabs/jsonrpcclient.git;branch=main;protocol=https"
+
+inherit python_setuptools_build_meta
+
+S = "${WORKDIR}/git"
+
+RDEPENDS:${PN} += "\
+ python3-json \
+ python3-math \
+ python3-netclient \
+"
+
+BBCLASSEXTEND = "native nativesdk"