aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-jsmin_3.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-jsmin_3.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsmin_3.0.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsmin_3.0.1.bb b/meta-python/recipes-devtools/python/python3-jsmin_3.0.1.bb
new file mode 100644
index 0000000000..c3129e7b53
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsmin_3.0.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "JavaScript minifier."
+HOMEPAGE = "https://github.com/tikitu/jsmin/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3a3301ce2ad647e172f4a1016c67324d"
+
+inherit setuptools3 pypi ptest
+SRC_URI[sha256sum] = "c0959a121ef94542e807a674142606f7e90214a2b3d1eb17300244bbb5cc2bfc"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://7a75d76c2d6bfb917f30ced8f5c0a9a4157f7819.patch \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/jsmin/test.py ${D}${PTEST_PATH}/
+}