aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/pyrtm_0.4.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/pyrtm_0.4.2.bb21
1 files changed, 20 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb b/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
index 72f0921e70..2272da91a5 100644
--- a/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
+++ b/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
@@ -10,7 +10,26 @@ SRC_URI[sha256sum] = "b2d701b25ad3f9a1542057f3eb492c5c1d7dbe2b8d1e8f763043dcc14e
inherit pypi setuptools
+PACKAGES =+ "${PN}-tests ${PN}-samples"
+
+FILES_${PN}-samples += " \
+ ${PYTHON_SITEPACKAGES_DIR}/rtm/samples \
+"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/rtm/tests \
+"
+
RDEPENDS_${PN} += "\
${PYTHON_PN}-json \
${PYTHON_PN}-netclient \
- "
+"
+
+RDEPENDS_${PN}-samples += " \
+ ${PN} \
+"
+
+RDEPENDS_${PN}-tests += " \
+ ${PN} \
+ ${PYTHON_PN}-unittest \
+"