aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb15
1 files changed, 4 insertions, 11 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
index ebc4af6d69..4f3d2d7128 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d217a23f408e91c94359447735bc1800"
DEPENDS = "dbus dbus-glib ncurses python libusb1 chrpath-native"
PROVIDES = "virtual/gpsd"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
file://0001-SConstruct-fix-DSO-build-for-ntpshm-garmin_monitor.patch \
@@ -15,20 +15,18 @@ SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \
file://gpsd-default \
- file://gpsd.service \
file://gpsd \
file://60-gpsd.rules \
"
SRC_URI[md5sum] = "c01353459faa68834309109d4e868460"
SRC_URI[sha256sum] = "79f7de9ead63c7f5d2c9a92e85b5f82e53323c4d451ef8e27ea265ac3ef9a70f"
-inherit scons update-rc.d python-dir systemd
+inherit scons update-rc.d python-dir
INITSCRIPT_NAME = "gpsd"
INITSCRIPT_PARAMS = "defaults 35"
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "${PN}.socket"
+SYSTEMD_OESCONS ??= "false"
export STAGING_INCDIR
export STAGING_LIBDIR
@@ -38,7 +36,7 @@ EXTRA_OESCONS = " \
libQgpsmm='false' \
debug='true' \
strip='false' \
- systemd='true' \
+ systemd='${SYSTEMD_OESCONS}' \
"
# this cannot be used, because then chrpath is not found and only static lib is built
# target=${HOST_SYS}
@@ -81,11 +79,6 @@ do_install_append() {
#support for python
install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
-
- #support for systemd
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service
- install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket
}
pkg_postinst_${PN}-conf() {