aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/socketcan/can-isotp_git.bb')
-rw-r--r--meta-oe/recipes-extended/socketcan/can-isotp_git.bb15
1 files changed, 11 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/socketcan/can-isotp_git.bb b/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
index 6ce3cab112..ab97356e9b 100644
--- a/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
+++ b/meta-oe/recipes-extended/socketcan/can-isotp_git.bb
@@ -1,12 +1,19 @@
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=72d977d697c3c05830fdff00a7448931"
-SRCREV = "6003f9997587e6a563cebf1f246bcd0eb6deff3d"
-PV = "1.0+git${SRCPV}"
+SRCREV = "7626d0a0707391970080d493ce69638719938da7"
+PV = "1.0+git"
+
+SRC_URI = "git://github.com/hartkopp/can-isotp.git;protocol=https;branch=master"
-SRC_URI = "git://github.com/hartkopp/can-isotp.git;protocol=https"
S = "${WORKDIR}/git"
inherit module
EXTRA_OEMAKE += "KERNELDIR=${STAGING_KERNEL_DIR}"
+
+do_install:append() {
+ install -Dm 644 ${S}/include/uapi/linux/can/isotp.h ${D}${includedir}/linux/can/isotp.h
+}
+
+SKIP_RECIPE[can-isotp] ?= "Not needed with kernel 5.10+"