aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python/python-numpy
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-numpy')
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/arm/config.h21
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/arm/numpyconfig.h17
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/mipsel/config.h21
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h17
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/trycompile.diff33
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/unbreak-assumptions.diff16
6 files changed, 125 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-numpy/arm/config.h b/meta-oe/recipes-devtools/python/python-numpy/arm/config.h
new file mode 100644
index 0000000000..17ef186d56
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/arm/config.h
@@ -0,0 +1,21 @@
+/* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */
+/* #define SIZEOF_SHORT 2 */
+/* #define SIZEOF_INT 4 */
+/* #define SIZEOF_LONG 4 */
+/* #define SIZEOF_FLOAT 4 */
+/* #define SIZEOF_DOUBLE 8 */
+#define SIZEOF_LONG_DOUBLE 12
+#define SIZEOF_PY_INTPTR_T 4
+/* #define SIZEOF_LONG_LONG 8 */
+#define SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+#define MATHLIB m
+#define HAVE_FLOAT_FUNCS
+#define HAVE_LOG1P
+#define HAVE_EXPM1
+#define HAVE_INVERSE_HYPERBOLIC
+#define HAVE_INVERSE_HYPERBOLIC_FLOAT
+#define HAVE_ISNAN
+#define HAVE_ISINF
+#define HAVE_RINT
+
diff --git a/meta-oe/recipes-devtools/python/python-numpy/arm/numpyconfig.h b/meta-oe/recipes-devtools/python/python-numpy/arm/numpyconfig.h
new file mode 100644
index 0000000000..c4bf6547f0
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/arm/numpyconfig.h
@@ -0,0 +1,17 @@
+/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
+/*
+ * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
+ * */
+#define NPY_SIZEOF_SHORT 2
+#define NPY_SIZEOF_INT 4
+#define NPY_SIZEOF_LONG 4
+#define NPY_SIZEOF_FLOAT 4
+#define NPY_SIZEOF_DOUBLE 8
+#define NPY_SIZEOF_LONGDOUBLE 12
+#define NPY_SIZEOF_PY_INTPTR_T 4
+#define NPY_NO_SMP 0
+
+#define NPY_SIZEOF_LONGLONG 8
+#define NPY_SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+
diff --git a/meta-oe/recipes-devtools/python/python-numpy/mipsel/config.h b/meta-oe/recipes-devtools/python/python-numpy/mipsel/config.h
new file mode 100644
index 0000000000..17ef186d56
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/mipsel/config.h
@@ -0,0 +1,21 @@
+/* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */
+/* #define SIZEOF_SHORT 2 */
+/* #define SIZEOF_INT 4 */
+/* #define SIZEOF_LONG 4 */
+/* #define SIZEOF_FLOAT 4 */
+/* #define SIZEOF_DOUBLE 8 */
+#define SIZEOF_LONG_DOUBLE 12
+#define SIZEOF_PY_INTPTR_T 4
+/* #define SIZEOF_LONG_LONG 8 */
+#define SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+#define MATHLIB m
+#define HAVE_FLOAT_FUNCS
+#define HAVE_LOG1P
+#define HAVE_EXPM1
+#define HAVE_INVERSE_HYPERBOLIC
+#define HAVE_INVERSE_HYPERBOLIC_FLOAT
+#define HAVE_ISNAN
+#define HAVE_ISINF
+#define HAVE_RINT
+
diff --git a/meta-oe/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h b/meta-oe/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h
new file mode 100644
index 0000000000..c4bf6547f0
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/mipsel/numpyconfig.h
@@ -0,0 +1,17 @@
+/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
+/*
+ * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
+ * */
+#define NPY_SIZEOF_SHORT 2
+#define NPY_SIZEOF_INT 4
+#define NPY_SIZEOF_LONG 4
+#define NPY_SIZEOF_FLOAT 4
+#define NPY_SIZEOF_DOUBLE 8
+#define NPY_SIZEOF_LONGDOUBLE 12
+#define NPY_SIZEOF_PY_INTPTR_T 4
+#define NPY_NO_SMP 0
+
+#define NPY_SIZEOF_LONGLONG 8
+#define NPY_SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+
diff --git a/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff b/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff
new file mode 100644
index 0000000000..3ab3d72f2c
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/trycompile.diff
@@ -0,0 +1,33 @@
+--- /tmp/setup.py 2008-09-01 10:37:44.000000000 +0200
++++ numpy-1.1.1/numpy/core/setup.py 2008-09-01 10:38:20.373198000 +0200
+@@ -80,8 +80,7 @@
+ raise SystemError,\
+ "Non-existing %s. Perhaps you need to install"\
+ " python-dev|python-devel." % (python_h)
+- result = config_cmd.try_run(tc,include_dirs=[python_include],
+- library_dirs = default_lib_dirs)
++ result = config_cmd.try_compile(tc)
+ if not result:
+ raise SystemError,"Failed to test configuration. "\
+ "See previous error messages for more information."
+@@ -95,7 +94,7 @@
+ if mathlib:
+ mathlibs_choices.insert(0,mathlib.split(','))
+ for libs in mathlibs_choices:
+- if config_cmd.try_run(tc,libraries=libs):
++ if config_cmd.try_compile(tc):
+ mathlibs = libs
+ break
+ else:
+@@ -180,10 +179,7 @@
+ " python-dev|python-devel." % (python_h)
+
+ config.numpy_include_dirs
+- result = config_cmd.try_run(testcode,
+- include_dirs = [python_include] + \
+- config.numpy_include_dirs,
+- library_dirs = default_lib_dirs)
++ result = config_cmd.try_compile(testcode)
+
+ if not result:
+ raise SystemError,"Failed to generate numpy configuration. "\
diff --git a/meta-oe/recipes-devtools/python/python-numpy/unbreak-assumptions.diff b/meta-oe/recipes-devtools/python/python-numpy/unbreak-assumptions.diff
new file mode 100644
index 0000000000..c5b448167f
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-numpy/unbreak-assumptions.diff
@@ -0,0 +1,16 @@
+--- /tmp/system_info.py 2008-08-22 00:38:16.000000000 +0200
++++ numpy-1.1.1/numpy/distutils/system_info.py 2008-08-22 00:40:33.013198000 +0200
+@@ -137,11 +137,8 @@
+ default_x11_lib_dirs = []
+ default_x11_include_dirs = []
+ else:
+- default_lib_dirs = ['/usr/local/lib', '/opt/lib', '/usr/lib',
+- '/opt/local/lib', '/sw/lib']
+- default_include_dirs = ['/usr/local/include',
+- '/opt/include', '/usr/include',
+- '/opt/local/include', '/sw/include']
++ default_lib_dirs = ['/non-existant-dir']
++ default_include_dirs = ['non-existant-dir']
+ default_src_dirs = ['.','/usr/local/src', '/opt/src','/sw/src']
+
+ try: