aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb4
-rw-r--r--meta-networking/recipes-kernel/netmap/netmap-modules_git.bb6
-rw-r--r--meta-networking/recipes-support/memcached/memcached_1.4.17.bb2
3 files changed, 6 insertions, 6 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
index e9b726c5fb..d24b81bc19 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
@@ -30,8 +30,8 @@ inherit update-rc.d systemd
python __anonymous () {
import re
- karch = d.getVar('KARCH', True)
- multilib = d.getVar('MLPREFIX', True)
+ karch = d.getVar('KARCH')
+ multilib = d.getVar('MLPREFIX')
if multilib and karch == 'powerpc64':
searchstr = "lib.?32"
diff --git a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb b/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
index e9eea56cd8..82b9b059d4 100644
--- a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
+++ b/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
@@ -33,8 +33,8 @@ NETMAP_DRIVERS ??= ""
NETMAP_ALL_DRIVERS = "ixgbe igb e1000e e1000 veth.c forcedeth.c virtio_net.c r8169.c"
python __anonymous () {
- drivers_list = d.getVar("NETMAP_DRIVERS", True).split()
- all_drivers_list = d.getVar("NETMAP_ALL_DRIVERS", True).split()
+ drivers_list = d.getVar("NETMAP_DRIVERS").split()
+ all_drivers_list = d.getVar("NETMAP_ALL_DRIVERS").split()
config_drivers = "--drivers=" + ",".join(drivers_list)
extra_oeconf_drivers = bb.utils.contains_any('NETMAP_DRIVERS', all_drivers_list, config_drivers, '--no-drivers', d)
@@ -70,7 +70,7 @@ do_configure_append () {
#define NETMAP_LINUX_HAVE_E1000E_DOWN2
EOF
-if ${@ 'false' if (bb.utils.vercmp_string(d.getVar('KERNEL_VERSION', True) or "0", '3.17') < 0) else 'true' } ; then
+if ${@ 'false' if (bb.utils.vercmp_string(d.getVar('KERNEL_VERSION') or "0", '3.17') < 0) else 'true' } ; then
echo OK
cat >> ${S}/LINUX/netmap_linux_config.h <<EOF
#define NETMAP_LINUX_ALLOC_NETDEV_4ARGS
diff --git a/meta-networking/recipes-support/memcached/memcached_1.4.17.bb b/meta-networking/recipes-support/memcached/memcached_1.4.17.bb
index 293f8d4c6d..2b36ba4f86 100644
--- a/meta-networking/recipes-support/memcached/memcached_1.4.17.bb
+++ b/meta-networking/recipes-support/memcached/memcached_1.4.17.bb
@@ -30,7 +30,7 @@ SRC_URI[md5sum] = "46402dfbd7faadf6182283dbbd18b1a6"
SRC_URI[sha256sum] = "d9173ef6d99ba798c982ea4566cb4f0e64eb23859fdbf9926a89999d8cdc0458"
python __anonymous () {
- endianness = d.getVar('SITEINFO_ENDIANNESS', True)
+ endianness = d.getVar('SITEINFO_ENDIANNESS')
if endianness == 'le':
d.appendVar('EXTRA_OECONF', " ac_cv_c_endian=little")
else: