aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/ippool/ippool_1.3.bb')
-rw-r--r--meta-networking/recipes-daemons/ippool/ippool_1.3.bb25
1 files changed, 14 insertions, 11 deletions
diff --git a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
index 6fa46904b3..36ea289945 100644
--- a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
+++ b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
@@ -9,7 +9,7 @@ addresses from ippoold. \
"
HOMEPAGE = "http://www.openl2tp.org/"
SECTION = "console/network"
-LICENSE = "GPLv2+"
+LICENSE = "GPL-2.0-or-later"
SRC_URI = "https://sourceforge.net/projects/openl2tp/files/${BPN}/${PV}/${BPN}-${PV}.tar.gz \
file://runtest.sh \
@@ -26,6 +26,11 @@ SRC_URI = "https://sourceforge.net/projects/openl2tp/files/${BPN}/${PV}/${BPN}-$
file://0003-cli-Mark-return-of-strtol-as-long-int.patch \
file://0002-link-with-libtirpc.patch \
file://0003-musl-fixes.patch \
+ file://strncpy-truncation.patch \
+ file://0001-pppd-ippool.c-Fix-type-casting-issues-between-in_add.patch \
+ file://0002-ippool_rpc_server.c-Add-missing-prototype-for-ippool.patch \
+ file://0001-Use-unsigned-int-type-for-1-bit-integer-bitfield.patch \
+ file://0001-ippool-Port-to-ppp-2.5-APIs.patch \
"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4c59283b82fc2b166455e0fc23c71c6f"
@@ -35,7 +40,7 @@ SRC_URI[sha256sum] = "d3eab7d6cad5da8ccc9d1e31d5303e27a39622c07bdb8fa3618eea3144
inherit systemd
DEPENDS = "readline ppp ncurses gzip-native rpcsvc-proto-native libtirpc"
-RDEPENDS_${PN} = "rpcbind"
+RDEPENDS:${PN} = "rpcbind"
EXTRA_OEMAKE = "CC='${CC}' AS='${AS}' LD='${LD}' AR='${AR}' NM='${NM}' STRIP='${STRIP}'"
EXTRA_OEMAKE += "PPPD_VERSION=${PPPD_VERSION} SYS_LIBDIR=${libdir}"
@@ -44,11 +49,9 @@ EXTRA_OEMAKE += "IPPOOL_TEST=y"
CPPFLAGS += "${SELECTED_OPTIMIZATION} -I${STAGING_INCDIR}/tirpc"
-SYSTEMD_SERVICE_${PN} = "ippool.service"
-SYSTEMD_AUTO_ENABLE = "disable"
+SYSTEMD_SERVICE:${PN} = "ippool.service"
-
-do_compile_prepend() {
+do_compile:prepend() {
# fix the CFLAGS= and CPPFLAGS= in main Makefile, to have the extra CFLAGS in env
sed -i -e "s/^CFLAGS=/CFLAGS+=/" ${S}/Makefile
sed -i -e "s/^CPPFLAGS=/CPPFLAGS+=/" ${S}/Makefile
@@ -78,12 +81,12 @@ do_install() {
PACKAGES =+ "${PN}-test"
-FILES_${PN} += "${libdir}/pppd/${PPPD_VERSION}/ippool.so"
-FILES_${PN}-dbg += "${libdir}/pppd/${PPPD_VERSION}/.debug/ippool.so"
-FILES_${PN}-test = "/opt/${BPN}"
+FILES:${PN} += "${libdir}/pppd/${PPPD_VERSION}/ippool.so"
+FILES:${PN}-dbg += "${libdir}/pppd/${PPPD_VERSION}/.debug/ippool.so"
+FILES:${PN}-test = "/opt/${BPN}"
# needs tcl to run tests
-RDEPENDS_${PN}-test += "tcl ${BPN}"
+RDEPENDS:${PN}-test += "tcl ${BPN}"
PPPD_VERSION="${@get_ppp_version(d)}"
@@ -95,7 +98,7 @@ def get_ppp_version(d):
return None
bb.debug(1, "pppd plugin dir %s" % pppd_plugin)
- r = re.compile("\d*\.\d*\.\d*")
+ r = re.compile(r"\d*\.\d*\.\d*")
for f in os.listdir(pppd_plugin):
if os.path.isdir(os.path.join(pppd_plugin, f)):
ma = r.match(f)