aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb2
-rw-r--r--meta-gnome/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
index 5052b36fc3..ec17c75e37 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
@@ -111,7 +111,7 @@ python populate_packages_prepend () {
d.setVar('FILES_' + metapkg, "")
blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
metapkg_rdepends = []
- packages = d.getVar('PACKAGES', 1).split()
+ packages = d.getVar('PACKAGES').split()
for pkg in packages[1:]:
if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
print("Modifying %s" % pkg)
diff --git a/meta-gnome/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb b/meta-gnome/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
index c0ac911a64..90ed5a4641 100644
--- a/meta-gnome/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
+++ b/meta-gnome/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
@@ -41,8 +41,8 @@ ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
UPSTREAM_CHECK_REGEX = "(?P<pver>2\.([0-8]*[02468])+(\.\d+)+)"
python populate_packages_prepend() {
- engines_root = os.path.join(d.getVar('libdir', True), "gtk-2.0/2.10.0/engines")
- themes_root = os.path.join(d.getVar('datadir', True), "themes")
+ engines_root = os.path.join(d.getVar('libdir'), "gtk-2.0/2.10.0/engines")
+ themes_root = os.path.join(d.getVar('datadir'), "themes")
do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')