aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-ptyprocess/run-ptest4
-rw-r--r--meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb19
2 files changed, 12 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ptyprocess/run-ptest b/meta-python/recipes-devtools/python/python3-ptyprocess/run-ptest
index 15c3f6282d..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-ptyprocess/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-ptyprocess/run-ptest
@@ -1,3 +1,3 @@
-#!/bin/sh
+#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb b/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb
index 2a8b8730c4..4abec0a01c 100644
--- a/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb
@@ -15,10 +15,10 @@ UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
S = "${WORKDIR}/${SRCNAME}-${PV}"
RDEPENDS:${PN} = "\
- ${PYTHON_PN}-core \
- ${PYTHON_PN}-fcntl \
- ${PYTHON_PN}-terminal \
- ${PYTHON_PN}-resource \
+ python3-core \
+ python3-fcntl \
+ python3-terminal \
+ python3-resource \
"
BBCLASSEXTEND = "native nativesdk"
@@ -30,11 +30,12 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-fcntl \
- ${PYTHON_PN}-terminal \
- ${PYTHON_PN}-resource \
- bash \
+ bash \
+ python3-fcntl \
+ python3-pytest \
+ python3-resource \
+ python3-terminal \
+ python3-unittest-automake-output \
"
do_install_ptest() {