aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-toml.inc10
-rw-r--r--meta-python/recipes-devtools/python/python3-toml_0.10.0.bb12
2 files changed, 10 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python-toml.inc b/meta-python/recipes-devtools/python/python-toml.inc
deleted file mode 100644
index a3b3dfc862..0000000000
--- a/meta-python/recipes-devtools/python/python-toml.inc
+++ /dev/null
@@ -1,10 +0,0 @@
-SUMMARY = "Python Library for Tom's Obvious, Minimal Language"
-HOMEPAGE = "https://github.com/uiri/toml"
-LICENSE = "MIT"
-SECTION = "devel/python"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=6d6012eea477117abf51c31262a152f8"
-
-SRC_URI[md5sum] = "63fffbe2d632865ec29cd69bfdf36682"
-SRC_URI[sha256sum] = "229f81c57791a41d65e399fc06bf0848bab550a9dfd5ed66df18ce5f05e73d5c"
-
-inherit pypi
diff --git a/meta-python/recipes-devtools/python/python3-toml_0.10.0.bb b/meta-python/recipes-devtools/python/python3-toml_0.10.0.bb
index cebb41a533..5a7b04c9e0 100644
--- a/meta-python/recipes-devtools/python/python3-toml_0.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-toml_0.10.0.bb
@@ -1,5 +1,13 @@
-inherit setuptools3
-require python-toml.inc
+SUMMARY = "Python Library for Tom's Obvious, Minimal Language"
+HOMEPAGE = "https://github.com/uiri/toml"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6d6012eea477117abf51c31262a152f8"
+
+SRC_URI[md5sum] = "63fffbe2d632865ec29cd69bfdf36682"
+SRC_URI[sha256sum] = "229f81c57791a41d65e399fc06bf0848bab550a9dfd5ed66df18ce5f05e73d5c"
+
+inherit pypi setuptools3
RDEPENDS_${PN} += " \
${PYTHON_PN}-misc \