aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-11-15 20:56:50 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-16 08:25:15 -0800
commitda0fb391cadd1272c488d2c780bf6b33ed6cec19 (patch)
treec3bd2cbe64d114ee1d8ce7e030a82224d1f18c9a /meta-python
parent1f5e1d37f8e6605e71b6c8fa2e4ac72ef0c52f84 (diff)
downloadmeta-openembedded-da0fb391cadd1272c488d2c780bf6b33ed6cec19.tar.gz
python3-frozenlist: Add recipe
A list-like structure which implements collections.abc.MutableSequence, and which can be made immutable. Version 1.2.0: - FrozenList now supports being used as a generic type as per PEP 585, e.g. frozen_int_list: FrozenList[int] (requires Python 3.9 or newer) - Added support for Python 3.10 - Started shipping platform-specific wheels with the musl tag targeting typical Alpine Linux runtimes - Started shipping platform-specific arm64 wheels for Apple Silicon Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb b/meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb
new file mode 100644
index 0000000000..b56e2e5e66
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-frozenlist_1.2.0.bb
@@ -0,0 +1,8 @@
+SUMMARY = "A list-like structure which implements collections.abc.MutableSequence, and which can be made immutable."
+HOMEPAGE = "https://github.com/aio-libs/frozenlist"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cf056e8e7a0a5477451af18b7b5aa98c"
+
+SRC_URI[sha256sum] = "68201be60ac56aff972dc18085800b6ee07973c49103a8aba669dee3d71079de"
+
+inherit pypi setuptools3