aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-12 10:41:44 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-12 10:42:45 -0700
commit3e5378b42a6daae114deb9dbdee2271cd9e7aed7 (patch)
tree5e3c69b392ab44511dcbd0ab66a4e5fa97f0effe /meta-python
parent7a75c2d6b4334ee7701158bdd63e8c5acbe3125f (diff)
downloadmeta-openembedded-3e5378b42a6daae114deb9dbdee2271cd9e7aed7.tar.gz
python3-pylint: Fix missing deps for ptests
Disable benchmarks in ptest run Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb13
2 files changed, 11 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pylint/run-ptest b/meta-python/recipes-devtools/python/python3-pylint/run-ptest
index b63c4de0d9..7a5ceedf95 100644
--- a/meta-python/recipes-devtools/python/python3-pylint/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-pylint/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --benchmark-disable -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb b/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
index 58f0616fcd..4a082066b6 100644
--- a/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pylint_2.17.3.bb
@@ -13,25 +13,32 @@ SRCREV ?= "389e14c36819cb87190fd412d3f366a3283f0078"
inherit python_setuptools_build_meta ptest
RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
+ ${PYTHON_PN}-dill \
${PYTHON_PN}-isort \
+ ${PYTHON_PN}-mccabe \
${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-platformdirs \
${PYTHON_PN}-shell \
${PYTHON_PN}-json \
${PYTHON_PN}-pkgutil \
${PYTHON_PN}-difflib \
${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-tomlkit \
"
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-core \
- ${PYTHON_PN}-dill \
${PYTHON_PN}-git \
- ${PYTHON_PN}-platformdirs \
+ ${PYTHON_PN}-py \
${PYTHON_PN}-pytest \
${PYTHON_PN}-pytest-benchmark \
+ ${PYTHON_PN}-pytest-runner \
+ ${PYTHON_PN}-pytest-timeout \
+ ${PYTHON_PN}-pytest-xdist \
+ ${PYTHON_PN}-requests \
${PYTHON_PN}-statistics \
- ${PYTHON_PN}-tomlkit \
${PYTHON_PN}-tomllib \
+ ${PYTHON_PN}-typing-extensions \
"
S = "${WORKDIR}/git"