aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2023-05-02 12:50:00 -0400
committerKhem Raj <raj.khem@gmail.com>2023-05-12 10:33:54 -0700
commit1410b40c2f04af9104220c967a81b2c4779efa6c (patch)
treecb18554fbca46cc4fabebe2158561fc40a3099d3 /meta-python
parenta179653ce204d90980f81aff66ef4fd5649568d5 (diff)
downloadmeta-openembedded-1410b40c2f04af9104220c967a81b2c4779efa6c.tar.gz
python3-platformdirs: Add recipe
Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-platformdirs/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb35
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
new file mode 100644
index 0000000000..b63c4de0d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb b/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
new file mode 100644
index 0000000000..b5ff369d04
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
@@ -0,0 +1,35 @@
+SUMMARY = "A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE = "https://github.com/platformdirs/platformdirs"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a"
+
+SRC_URI = " \
+ git://github.com/platformdirs/platformdirs.git;branch=main;protocol=https \
+ file://run-ptest \
+"
+
+SRCREV ?= "dcb56802714f5570236c86d03773ff881be6e39f"
+SRC_URI[sha256sum] = "7954a68d0ba23558d753f73437c55f89027cf8f5108c19844d4b82e5af396335"
+
+inherit python_setuptools_build_meta ptest
+
+DEPENDS += " \
+ python3-hatch-vcs-native \
+ python3-setuptools-scm-native \
+ python3-toml-native \
+"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-appdirs \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-pytest-mock \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/Tests
+ cp -rf ${S}/tests ${D}${PTEST_PATH}/
+}
+
+BBCLASSEXTEND = "native"