aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-04-12 12:33:43 +0300
committerKhem Raj <raj.khem@gmail.com>2024-04-12 08:57:34 -0700
commitcf4bf3f13aeec49072d6e6c24e1ff005236e94c2 (patch)
tree7c83e8b7c27c94f94605de8eacc4a9ca3651a0d0 /meta-python/recipes-devtools
parentb4980bfc97916f4896ac4a723f9a35a675c4228c (diff)
downloadmeta-openembedded-cf4bf3f13aeec49072d6e6c24e1ff005236e94c2.tar.gz
python3-ecdsa: enable ptest and add missing runtime dependency
* Ptest and library example tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_SLOW_META_PYTHON Ptest result: ============= qemux86-64: Testsuite summary TOTAL: 1976 PASS: 1972 SKIP: 4 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 292 END: /usr/lib/python3-ecdsa/ptest 2024-04-12T09:18 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 1976 PASS: 1972 SKIP: 4 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 236 END: /usr/lib/python3-ecdsa/ptest 2024-04-12T09:05 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-ecdsa/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb27
2 files changed, 26 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ecdsa/run-ptest b/meta-python/recipes-devtools/python/python3-ecdsa/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ecdsa/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb b/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
index 5b4f7eb93f..8e967f9259 100644
--- a/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ecdsa_0.19.0.bb
@@ -6,12 +6,31 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=66ffc5e30f76cbb5358fe54b645e5a1d"
PYPI_PACKAGE = "ecdsa"
SRC_URI[sha256sum] = "60eaad1199659900dd0af521ed462b793bbdf867432b3948e87416ae4caf6bf8"
-inherit pypi setuptools3 python3native
+inherit pypi setuptools3 python3native ptest
-RDEPENDS:${PN} += "python3-six python3-gmpy2"
+SRC_URI += " \
+ file://run-ptest \
+"
-BBCLASSEXTEND = "native nativesdk"
+RDEPENDS:${PN}-ptest += " \
+ python3-hypothesis \
+ python3-pytest \
+ python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/src/ecdsa/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS:${PN} += " \
+ python3-gmpy2 \
+ python3-json \
+ python3-six \
+"
do_install:append() {
- rm ${D}${PYTHON_SITEPACKAGES_DIR}/ecdsa/test_*.py
+ rm ${D}${PYTHON_SITEPACKAGES_DIR}/ecdsa/test_*.py
}
+
+BBCLASSEXTEND = "native nativesdk"