aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:33 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commit4ecf8c7780105f155800098de7418c6ee47be388 (patch)
tree010e16a223c46aedc855af2eb5aa4e7ecc677dd1 /meta-python/recipes-devtools
parent2d02cdc62619b0681daa80dce8b08d381bc2fb41 (diff)
downloadmeta-openembedded-4ecf8c7780105f155800098de7418c6ee47be388.tar.gz
python-stevedore: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-stevedore.inc15
-rw-r--r--meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb17
2 files changed, 15 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-stevedore.inc b/meta-python/recipes-devtools/python/python-stevedore.inc
deleted file mode 100644
index 5aa9fb424c..0000000000
--- a/meta-python/recipes-devtools/python/python-stevedore.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "Manage dynamic plugins for Python applications"
-HOMEPAGE = "https://github.com/dreamhost/stevedore"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-SRC_URI[md5sum] = "42fa2bf0251c96b543765c5ce13f37c9"
-SRC_URI[sha256sum] = "e0739f9739a681c7a1fda76a102b65295e96a144ccdb552f2ae03c5f0abe8a14"
-
-inherit pypi
-
-DEPENDS += "${PYTHON_PN}-pbr-native"
-
-RDEPENDS_${PN} += "${PYTHON_PN}-pbr ${PYTHON_PN}-six"
-
-BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb b/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb
index 3f557f2cbf..b985ca5b13 100644
--- a/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb
+++ b/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb
@@ -1,2 +1,15 @@
-inherit setuptools3
-require python-stevedore.inc
+DESCRIPTION = "Manage dynamic plugins for Python applications"
+HOMEPAGE = "https://github.com/dreamhost/stevedore"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "42fa2bf0251c96b543765c5ce13f37c9"
+SRC_URI[sha256sum] = "e0739f9739a681c7a1fda76a102b65295e96a144ccdb552f2ae03c5f0abe8a14"
+
+DEPENDS += "${PYTHON_PN}-pbr-native"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pbr ${PYTHON_PN}-six"
+
+BBCLASSEXTEND = "native"