aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-24 19:31:37 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-28 12:23:15 -0700
commit1c9c648e5924c854c8645147811b99cf85e2c710 (patch)
tree3d2bf9ed5f7f3b048290eed9d5737949b7aab4c9 /meta-python/recipes-devtools/python
parent9f2c5ed0d984725a5cf2e82789bc4e2fe0d0e1ba (diff)
downloadmeta-openembedded-1c9c648e5924c854c8645147811b99cf85e2c710.tar.gz
python3-matplotlib: Upgrade 3.2.2 -> 3.3.0
Upgrade to release 3.3.0: - Provisional API for composing semantic axes layouts from text or nested lists - New Axes.sharex, Axes.sharey methods - Turbo colormap - colors.BoundaryNorm supports extend keyword argument - Text color for legend labels - Pcolor and Pcolormesh now accept shading='nearest' and 'auto' - Allow tick formatters to be set with str or function inputs - New Axes.axline method - Dates use a modern epoch - Improved font weight detection - Axes3D no longer distorts the 3D plot to match the 2D aspect ratio - More consistent toolbar behavior across backends - Toolbar icons are now styled for dark themes - Cursor text now uses a number of significant digits matching pointing precision - Functions to compute a Path's size - savefig() gained a backend keyword argument - Saving SVG now supports adding metadata - Saving PDF metadata via PGF now consistent with PDF backend - NbAgg and WebAgg no longer use jQuery & jQuery UI Create setup.cfg with configuration to use the copy of FreeType installed on the system. License-Update: The line and the checksum of the license in setup.py has changed but the license remains the same. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.3.0.bb (renamed from meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb)11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.3.0.bb
index b32177d9b4..2e88efb563 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.3.0.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "https://github.com/matplotlib/matplotlib"
SECTION = "devel/python"
LICENSE = "PSF"
LIC_FILES_CHKSUM = "\
- file://setup.py;beginline=253;endline=253;md5=2a114620e4e6843aa7568d5902501753 \
+ file://setup.py;beginline=251;endline=251;md5=e0ef37de7122ce842bcd1fb54482b353 \
file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
"
DEPENDS = "\
@@ -18,8 +18,8 @@ DEPENDS = "\
python3-pytz-native \
"
-SRC_URI[md5sum] = "b60cd68f792a30173d825e16482aedd8"
-SRC_URI[sha256sum] = "3d77a6630d093d74cbbfebaa0571d00790966be1ed204e4a8239f5cbd6835c5d"
+SRC_URI[md5sum] = "b1de7185687c6f5c092689e3431a69b3"
+SRC_URI[sha256sum] = "24e8db94948019d531ce0bcd637ac24b1c8f6744ac86d2aa0eb6dbaeb1386f82"
inherit pypi setuptools3 pkgconfig
@@ -34,4 +34,9 @@ RDEPENDS_${PN} = "\
python3-pytz \
"
+do_compile_prepend() {
+ echo [libs] > ${S}/setup.cfg
+ echo system_freetype = true >> ${S}/setup.cfg
+}
+
BBCLASSEXTEND = "native"