aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-websockets_8.1.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-01-17 15:11:28 +0800
committerKhem Raj <raj.khem@gmail.com>2020-01-17 15:44:06 -0800
commita4ed492332659c62b00bcd3bf5d6235ca1b386fe (patch)
treef7a8478ea4da5fcce6710cacb2aac8cf96953dbf /meta-python/recipes-devtools/python/python3-websockets_8.1.bb
parent3a65893b3bc3eab54adc6dda4609ee432fae58d6 (diff)
downloadmeta-openembedded-a4ed492332659c62b00bcd3bf5d6235ca1b386fe.tar.gz
python3-websockets: upgrade 8.0.2 -> 8.1
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-websockets_8.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-websockets_8.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-websockets_8.1.bb b/meta-python/recipes-devtools/python/python3-websockets_8.1.bb
new file mode 100644
index 0000000000..b09e978af7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-websockets_8.1.bb
@@ -0,0 +1,16 @@
+SUMMARY = "An implementation of the WebSocket Protocol (RFC 6455)"
+HOMEPAGE = "https://github.com/aaugustin/websockets"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ad5c6d36b3d0098b2f33a5ab69a9e750"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "f12d7f31fe8d0b3e65c12f845bcd0ad8"
+SRC_URI[sha256sum] = "5c65d2da8c6bce0fca2528f69f44b2f977e06954c8512a952222cea50dad430f"
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-asyncio \
+"