aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-websocket-client_0.57.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-03 12:30:12 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-06 10:20:25 -0700
commitd1de4a0cb070988d2b7ba2b157075db75fd9a260 (patch)
tree53e34ef486624a4e2e27cd73c6bba3c9f8cc567d /meta-python/recipes-devtools/python/python3-websocket-client_0.57.0.bb
parent3fe932abb1b48d2507e0415a7839a0324ff0f21b (diff)
downloadmeta-openembedded-d1de4a0cb070988d2b7ba2b157075db75fd9a260.tar.gz
python3-websocket-client: Upgrade 0.56.0 -> 0.57.0
Upgrade to release 0.57.0: - wsdump: Fix --headers option - Fix getting 400 bad request with long proxy authorization string - Fix for errors that occur when closing websocket from another thread - avoid calling repr(data) if tracing is not enabled - Fixed typo - Create dummy `ssl` object - Show compressed text messages in wsdump.py - Resolve issue opening socket to intranet on Windows 10 with no proxy settings but behind proxy - Expose http connection header to user - Improve the readability of HTTP status codes. - fix the compatible issue with gevent+dnspython - v should be checked for emptry string before splitting it - _handshake: hasattr checks on six before accessing the values Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-websocket-client_0.57.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-websocket-client_0.57.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-websocket-client_0.57.0.bb b/meta-python/recipes-devtools/python/python3-websocket-client_0.57.0.bb
new file mode 100644
index 0000000000..aaa92f3ccb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-websocket-client_0.57.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "websocket client for python"
+DESCRIPTION = "\
+websocket-client module is WebSocket client for python. \
+This provide the low level APIs for WebSocket. All APIs \
+are the synchronous functions."
+HOMEPAGE = "https://github.com/websocket-client/websocket-client"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c4c4a98fbc4836b81c8c64d6ecb01fc1"
+
+SRC_URI[md5sum] = "8061820da5e1de26a6a1a6996d4eebd5"
+SRC_URI[sha256sum] = "d735b91d6d1692a6a181f2a8c9e0238e5f6373356f561bb9dc4c7af36f452010"
+
+PYPI_PACKAGE = "websocket_client"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-six \
+"